See ChangeLog: Sat May 22 22:47:26 CEST 1999 Werner Koch
authorWerner Koch <wk@gnupg.org>
Sat, 22 May 1999 20:54:52 +0000 (20:54 +0000)
committerWerner Koch <wk@gnupg.org>
Sat, 22 May 1999 20:54:52 +0000 (20:54 +0000)
cipher/dynload.c
configure.in
scripts/ChangeLog
scripts/autogen.sh

index ae3de3f..6caeb06 100644 (file)
@@ -170,7 +170,7 @@ register_internal_cipher_extension(
     }
     /* and register */
     el->enumfunc = enumfunc;
-  #ifdef HAVE_DL_OPEN
+  #ifdef HAVE_DL_DLOPEN
     el->handle = (void*)1;
   #else
     el->handle = 1;
index 944325d..3d0581a 100644 (file)
@@ -143,7 +143,7 @@ case "${target}" in
         try_gettext="no"
         try_gdbm="no"
         ;;
-    i386-emx-os2)
+    i386-emx-os2 | i[3456]86-pc-os2emx )
         # OS/2 with the EMX environment
         ac_cv_have_dev_random=no
         AC_DEFINE(HAVE_DRIVE_LETTERS)
@@ -182,7 +182,7 @@ case "${target}" in
     i386--mingw32)
         PRINTABLE_OS_NAME="MingW32"
         ;;
-    i386-emx-os2)
+    i386-emx-os2 | i[3456]86-pc-os2emx)
         PRINTABLE_OS_NAME="OS/2"
         ;;
     *-linux*)
@@ -353,7 +353,7 @@ if test "$use_static_rnd" = default; then
           i386--mingw32)
               static_modules="$static_modules rndw32"
               ;;
-          i386-emx-os2)
+          i386-emx-os2|i[3456]86-pc-os2emx)
               static_modules="$static_modules rndos2"
               ;;
           m68k-atari-mint)
index 1ccecc8..14765db 100644 (file)
@@ -1,3 +1,7 @@
+Sat May 22 22:47:26 CEST 1999  Werner Koch  <wk@isil.d.shuttle.de>
+
+       * autogen.sh: Fixed the error message for a missing libtool.
+
 Sat May  8 19:28:08 CEST 1999  Werner Koch  <wk@isil.d.shuttle.de>
 
        * mkinstalldirs, install-sh: New from GNU repository
index 5060661..266eb75 100755 (executable)
@@ -75,8 +75,8 @@ if (libtool --version) < /dev/null > /dev/null 2>&1 ; then
     fi
 else
     echo
-    echo "**Error**: You must have "\`autoconf\'" installed to compile $PGM."
-    echo '           (version ' $autoconf_vers ' or newer is required)'
+    echo "**Error**: You must have "\`libtool\'" installed to compile $PGM."
+    echo '           (version ' $libtool_vers ' or newer is required)'
     DIE="yes"
 fi