Release 1.7.1 libgcrypt-1.7.1
authorWerner Koch <wk@gnupg.org>
Wed, 15 Jun 2016 07:34:02 +0000 (09:34 +0200)
committerWerner Koch <wk@gnupg.org>
Wed, 15 Jun 2016 07:34:02 +0000 (09:34 +0200)
NEWS
README
configure.ac

diff --git a/NEWS b/NEWS
index 777c1e5..e0113fc 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,24 @@
-Noteworthy changes in version 1.7.1 (unreleased)  [C21/A1/R_]
+Noteworthy changes in version 1.7.1 (2016-06-15)  [C21/A1/R1]
 ------------------------------------------------
 
+ * Bug fixes:
+
+   - Fix ecc_verify for cofactor support.
+
+   - Fix portability bug when using gcc with Solaris 9 SPARC.
+
+   - Build fix for OpenBSD/amd64
+
+   - Add OIDs to the Serpent ciphers.
+
+ * Internal changes:
+
+   - Use getrandom system call on Linux if available.
+
+   - Blinding is now also used for RSA signature creation.
+
+   - Changed names of debug envvars
+
 
 Noteworthy changes in version 1.7.0 (2016-04-15)  [C21/A1/R0]
 ------------------------------------------------
diff --git a/README b/README
index f9f49b5..1148a24 100644 (file)
--- a/README
+++ b/README
     The download canonical location for libgcrypt is:
 
       ftp://ftp.gnupg.org/gcrypt/libgcrypt/
+    or
+      https://gnupg.org/ftp/gcrypt/libgcrypt/
 
     To build libgcrypt you need libgpg-error:
 
       ftp://ftp.gnupg.org/gcrypt/libgpg-error/
+    or
+      https://gnupg.org/ftp/gcrypt/libgpg-error/
 
     You should get the latest versions of course.
 
index ad0f64d..d0c7f9c 100644 (file)
@@ -56,7 +56,7 @@ AC_INIT([libgcrypt],[mym4_full_version],[http://bugs.gnupg.org])
 #   (No interfaces changed:                   REVISION++)
 LIBGCRYPT_LT_CURRENT=21
 LIBGCRYPT_LT_AGE=1
-LIBGCRYPT_LT_REVISION=0
+LIBGCRYPT_LT_REVISION=1
 
 
 # If the API is changed in an incompatible way: increment the next counter.