Release 1.8.1 libgcrypt-1.8.1
authorWerner Koch <wk@gnupg.org>
Sun, 27 Aug 2017 07:22:09 +0000 (09:22 +0200)
committerWerner Koch <wk@gnupg.org>
Sun, 27 Aug 2017 07:22:09 +0000 (09:22 +0200)
* configure.ac: Set LT version to C22/A2/R1.

Signed-off-by: Werner Koch <wk@gnupg.org>
NEWS
configure.ac

diff --git a/NEWS b/NEWS
index 4ca8bc2..39f70a3 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,19 @@
-Noteworthy changes in version 1.8.1 (unreleased)  [C22/A2/R_]
+Noteworthy changes in version 1.8.1 (2017-08-27)  [C22/A2/R1]
 ------------------------------------------------
 
+ * Bug fixes:
+
+   - Mitigate a local side-channel attack on Curve25519 dubbed "May
+     the Fourth be With You".  [CVE-2017-0379] [also in 1.7.9]
+
+   - Add more extra bytes to the pool after reading a seed file.
+
+   - Add the OID SHA384WithECDSA from RFC-7427 to SHA-384.
+
+   - Fix build problems with the Jitter RNG
+
+   - Fix assembler code build problems on Rasbian (ARMv8/AArch32-CE).
+
 
 Noteworthy changes in version 1.8.0 (2017-07-18)  [C22/A2/R0]
 ------------------------------------------------
index 66e7cd6..7a78e30 100644 (file)
@@ -56,7 +56,7 @@ AC_INIT([libgcrypt],[mym4_full_version],[http://bugs.gnupg.org])
 #   (No interfaces changed:                   REVISION++)
 LIBGCRYPT_LT_CURRENT=22
 LIBGCRYPT_LT_AGE=2
-LIBGCRYPT_LT_REVISION=0
+LIBGCRYPT_LT_REVISION=1
 
 
 # If the API is changed in an incompatible way: increment the next counter.