issue #warning only for gcc. V1-1-6
authorWerner Koch <wk@gnupg.org>
Thu, 7 Feb 2002 19:16:55 +0000 (19:16 +0000)
committerWerner Koch <wk@gnupg.org>
Thu, 7 Feb 2002 19:16:55 +0000 (19:16 +0000)
Ready to release 1.1.6

mpi/mpicoder.c
src/gcrypt.h

index 753505b..c026c93 100644 (file)
@@ -188,7 +188,9 @@ mpi_print( FILE *fp, MPI a, int mode )
     return n;
 }
 
+#if __GNUC__ >= 2
 #warning We should move this function to elsewhere
+#endif
 void
 _gcry_log_mpidump( const char *text, MPI a )
 {
@@ -339,7 +341,9 @@ gcry_mpi_scan( struct gcry_mpi **ret_mpi, enum gcry_mpi_format format,
     /* TODO: add a way to allocate the MPI in secure memory
      * Hmmm: maybe it is better to retrieve this information from
      * the provided buffer. */
-     #warning secure memory is not used here.
+#if __GNUC__ >= 2
+#warning secure memory is not used here.
+#endif
     if( format == GCRYMPI_FMT_STD ) {
        const byte *s = buffer;
 
index 5c8a867..176f09d 100644 (file)
@@ -35,7 +35,7 @@ extern "C" {
  * header matches the installed library.
  * Note: Do not edit the next line as configure may fix the string here.
  */
-#define GCRYPT_VERSION "1.1.5a-cvs"
+#define GCRYPT_VERSION "1.1.6"
 
 
 #ifndef HAVE_BYTE_TYPEDEF