* configure.ac: Define AM conditional HAVE_OPENSC.
[gnupg.git] / configure.ac
1 # configure.ac - for GnuPG 1.9
2 # Copyright (C) 1998, 1999, 2000, 2001, 2002,
3 #               2003, 2004 Free Software Foundation, Inc.
4
5 # This file is part of GnuPG.
6
7 # GnuPG is free software; you can redistribute it and/or modify
8 # it under the terms of the GNU General Public License as published by
9 # the Free Software Foundation; either version 2 of the License, or
10 # (at your option) any later version.
11
12 # GnuPG is distributed in the hope that it will be useful,
13 # but WITHOUT ANY WARRANTY; without even the implied warranty of
14 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
15 # GNU General Public License for more details.
16
17 # You should have received a copy of the GNU General Public License
18 # along with this program; if not, write to the Free Software
19 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
20
21 # Process this file with autoconf to produce a configure script.
22 AC_PREREQ(2.52)
23 min_automake_version="1.7.6"
24
25 # Version number: Remember to change it immediately *after* a release.
26 #                 Add a "-cvs" prefix for non-released code.
27 AC_INIT(gnupg, 1.9.10, gnupg-devel@gnupg.org)
28 # Set development_version to yes if the minor number is odd or you
29 # feel that the default check for a development version is not
30 # sufficient.
31 development_version=yes
32 NEED_GPG_ERROR_VERSION=0.7
33
34 NEED_LIBGCRYPT_API=1
35 NEED_LIBGCRYPT_VERSION=1.1.94
36
37 NEED_LIBASSUAN_VERSION=0.6.6
38
39 NEED_KSBA_VERSION=0.9.7
40
41 NEED_OPENSC_VERSION=0.8.0
42
43
44
45 PACKAGE=$PACKAGE_NAME
46 PACKAGE_GT=${PACKAGE_NAME}2
47 VERSION=$PACKAGE_VERSION
48
49 AC_CONFIG_AUX_DIR(scripts)
50 AC_CONFIG_SRCDIR(sm/gpgsm.c)
51 AM_CONFIG_HEADER(config.h)
52 AC_CANONICAL_TARGET()
53 AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
54
55 AC_GNU_SOURCE
56
57 # Some status variables to give feedback at the end of a configure run
58 have_gpg_error=no
59 have_libgcrypt=no 
60 have_libassuan=no
61 have_ksba=no
62 have_opensc=no
63 have_pth=no
64
65 GNUPG_BUILD_PROGRAM(gpg, yes)
66 GNUPG_BUILD_PROGRAM(gpgsm, yes)
67 GNUPG_BUILD_PROGRAM(agent, yes)
68 GNUPG_BUILD_PROGRAM(scdaemon, yes)
69
70
71 AC_SUBST(PACKAGE)
72 AC_SUBST(PACKAGE_GT)
73 AC_SUBST(VERSION)
74 AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE", [Name of this package])
75 AC_DEFINE_UNQUOTED(PACKAGE_GT, "$PACKAGE_GT",
76                                 [Name of this package for gettext])
77 AC_DEFINE_UNQUOTED(VERSION, "$VERSION", [Version of this package])
78 AC_DEFINE_UNQUOTED(PACKAGE_BUGREPORT, "$PACKAGE_BUGREPORT",
79                                         [Bug report address])
80 AC_DEFINE_UNQUOTED(NEED_LIBGCRYPT_VERSION, "$NEED_LIBGCRYPT_VERSION",
81                                        [Required version of Libgcrypt])
82 AC_DEFINE_UNQUOTED(NEED_KSBA_VERSION, "$NEED_KSBA_VERSION",
83                                        [Required version of Libksba])
84
85
86
87 # The default is to use the modules from this package and the few
88 # other packages in a standard place; i.e where this package gets
89 # installed.  With these options it is possible to override these
90 # ${prefix} depended values with fixed paths, which can't be replaced
91 # at make time.  See also am/cmacros.am and the defaults in AH_BOTTOM.
92 AC_ARG_WITH(agent-pgm,
93     [  --with-agent-pgm=PATH  Use PATH as the default for the agent)],
94           GNUPG_AGENT_PGM="$withval", GNUPG_AGENT_PGM="" )
95 AC_SUBST(GNUPG_AGENT_PGM)
96 AM_CONDITIONAL(GNUPG_AGENT_PGM, test -n "$GNUPG_AGENT_PGM")
97 show_gnupg_agent_pgm="(default)"
98 test -n "$GNUPG_AGENT_PGM" && show_gnupg_agent_pgm="$GNUPG_AGENT_PGM"
99
100 AC_ARG_WITH(pinentry-pgm,
101     [  --with-pinentry-pgm=PATH  Use PATH as the default for the pinentry)],
102           GNUPG_PINENTRY_PGM="$withval", GNUPG_PINENTRY_PGM="" )
103 AC_SUBST(GNUPG_PINENTRY_PGM)
104 AM_CONDITIONAL(GNUPG_PINENTRY_PGM, test -n "$GNUPG_PINENTRY_PGM")
105 show_gnupg_pinentry_pgm="(default)"
106 test -n "$GNUPG_PINENTRY_PGM" && show_gnupg_pinentry_pgm="$GNUPG_PINENTRY_PGM"
107
108
109 AC_ARG_WITH(scdaemon-pgm,
110     [  --with-scdaemon-pgm=PATH  Use PATH as the default for the scdaemon)],
111           GNUPG_SCDAEMON_PGM="$withval", GNUPG_SCDAEMON_PGM="" )
112 AC_SUBST(GNUPG_SCDAEMON_PGM)
113 AM_CONDITIONAL(GNUPG_SCDAEMON_PGM, test -n "$GNUPG_SCDAEMON_PGM")
114 show_gnupg_scdaemon_pgm="(default)"
115 test -n "$GNUPG_SCDAEMON_PGM" && show_gnupg_scdaemon_pgm="$GNUPG_SCDAEMON_PGM"
116
117
118 AC_ARG_WITH(dirmngr-pgm,
119     [  --with-dirmngr-pgm=PATH  Use PATH as the default for the dirmngr)],
120           GNUPG_DIRMNGR_PGM="$withval", GNUPG_DIRMNGR_PGM="" )
121 AC_SUBST(GNUPG_DIRMNGR_PGM)
122 AM_CONDITIONAL(GNUPG_DIRMNGR_PGM, test -n "$GNUPG_DIRMNGR_PGM")
123 show_gnupg_dirmngr_pgm="(default)"
124 test -n "$GNUPG_DIRMNGR_PGM" && show_gnupg_dirmngr_pgm="$GNUPG_DIRMNGR_PGM"
125
126 AC_ARG_WITH(protect-tool-pgm,
127     [  --with-protect-tool-pgm=PATH  Use PATH as the default for the protect-tool)],
128           GNUPG_PROTECT_TOOL_PGM="$withval", GNUPG_PROTECT_TOOL_PGM="" )
129 AC_SUBST(GNUPG_PROTECT_TOOL_PGM)
130 AM_CONDITIONAL(GNUPG_PROTECT_TOOL_PGM, test -n "$GNUPG_PROTECT_TOOL_PGM")
131 show_gnupg_protect_tool_pgm="(default)"
132 test -n "$GNUPG_PROTECT_TOOL_PGM" \
133       && show_gnupg_protect_tool_pgm="$GNUPG_PROTECT_TOOL_PGM"
134
135
136 # Some folks want to use only the agent form this packet.  Make it
137 # easier for them by providing the configure option
138 # --enable-only-agent.
139 AC_ARG_ENABLE(agent-only,
140     AC_HELP_STRING([--enable-agent-only],[build only the gpg-agent]),
141     build_agent_only=$enableval)
142
143
144 # Configure option to allow ot disallow execution of external
145 # programs, like a photo viewer.
146 AC_MSG_CHECKING([whether to enable external program execution])
147 AC_ARG_ENABLE(exec,
148     AC_HELP_STRING([--disable-exec],[disable all external program execution]),
149     use_exec=$enableval)
150 AC_MSG_RESULT($use_exec)
151 if test "$use_exec" = no ; then
152     AC_DEFINE(NO_EXEC,1,[Define to disable all external program execution])
153 fi
154
155 if test "$use_exec" = yes ; then
156   AC_MSG_CHECKING([whether to enable photo ID viewing])
157   AC_ARG_ENABLE(photo-viewers,
158       [  --disable-photo-viewers disable photo ID viewers],
159       [if test "$enableval" = no ; then
160          AC_DEFINE(DISABLE_PHOTO_VIEWER,1,[define to disable photo viewing])
161       fi],enableval=yes)
162   gnupg_cv_enable_photo_viewers=$enableval
163   AC_MSG_RESULT($enableval)
164
165   if test "$gnupg_cv_enable_photo_viewers" = yes ; then
166     AC_MSG_CHECKING([whether to use a fixed photo ID viewer])
167     AC_ARG_WITH(photo-viewer,
168         [  --with-photo-viewer=FIXED_VIEWER  set a fixed photo ID viewer],
169         [if test "$withval" = yes ; then
170            withval=no
171         elif test "$withval" != no ; then
172            AC_DEFINE_UNQUOTED(FIXED_PHOTO_VIEWER,"$withval",
173                             [if set, restrict photo-viewer to this])
174         fi],withval=no)
175     AC_MSG_RESULT($withval)
176   fi
177
178   AC_MSG_CHECKING([whether to enable external keyserver helpers])
179   AC_ARG_ENABLE(keyserver-helpers,
180       [  --disable-keyserver-helpers  disable all external keyserver support],
181       [if test "$enableval" = no ; then
182          AC_DEFINE(DISABLE_KEYSERVER_HELPERS,1,
183                   [define to disable keyserver helpers])
184       fi],enableval=yes)
185   gnupg_cv_enable_keyserver_helpers=$enableval
186   AC_MSG_RESULT($enableval)
187
188   if test "$gnupg_cv_enable_keyserver_helpers" = yes ; then
189     AC_MSG_CHECKING([whether LDAP keyserver support is requested])
190     AC_ARG_ENABLE(ldap,
191     [  --disable-ldap          disable LDAP keyserver interface],
192         try_ldap=$enableval, try_ldap=yes)
193     AC_MSG_RESULT($try_ldap)
194
195     AC_MSG_CHECKING([whether HKP keyserver support is requested])
196     AC_ARG_ENABLE(hkp,
197     [  --disable-hkp           disable HKP keyserver interface],
198         try_hkp=$enableval, try_hkp=yes)
199     AC_MSG_RESULT($try_hkp)
200
201     if test "$try_hkp" = yes ; then
202       AC_SUBST(GPGKEYS_HKP,"gpgkeys_hkp$EXEEXT")
203     fi
204
205     AC_MSG_CHECKING([whether email keyserver support is requested])
206     AC_ARG_ENABLE(mailto,
207     [  --disable-mailto        disable email keyserver interface],
208         try_mailto=$enableval, try_mailto=yes)
209     AC_MSG_RESULT($try_mailto)
210     fi
211
212     AC_MSG_CHECKING([whether keyserver exec-path is enabled])
213     AC_ARG_ENABLE(keyserver-path,
214         [  --disable-keyserver-path disable the exec-path option for keyserver helpers],
215         [if test "$enableval" = no ; then
216          AC_DEFINE(DISABLE_KEYSERVER_PATH,1,[define to disable exec-path for keyserver helpers])
217         fi],enableval=yes)
218     AC_MSG_RESULT($enableval)
219   fi
220
221 AC_MSG_CHECKING([whether the included zlib is requested])
222 AC_ARG_WITH(included-zlib,
223     [  --with-included-zlib    use the zlib code included here],
224 [g10_force_zlib=yes], [g10_force_zlib=no] )
225 AC_MSG_RESULT($g10_force_zlib)
226
227 dnl
228 dnl Check whether we want to use Linux capabilities
229 dnl
230 AC_MSG_CHECKING([whether use of capabilities is requested])
231 AC_ARG_WITH(capabilities,
232     [  --with-capabilities     use linux capabilities [default=no]],
233 [use_capabilities="$withval"],[use_capabilities=no])
234 AC_MSG_RESULT($use_capabilities)
235
236
237 AH_BOTTOM([
238 /* Some global constants. */
239 #ifdef HAVE_DRIVE_LETTERS
240 #define GNUPG_DEFAULT_HOMEDIR "c:/gnupg"
241 #elif defined(__VMS)
242 #define GNUPG_DEFAULT_HOMEDIR "/SYS\$LOGIN/gnupg" 
243 #else
244 #define GNUPG_DEFAULT_HOMEDIR "~/.gnupg"
245 #endif 
246 #define GNUPG_PRIVATE_KEYS_DIR "private-keys-v1.d"
247
248 /* Tell libgcrypt not to use its own libgpg-error implementation. */
249 #define USE_LIBGPG_ERROR 1
250
251 /* This is the major version number of GnuPG so that
252    source included files can test for this.  Note, that\
253    we use 2 here even for GnuPG 1.9.x. */
254 #define GNUPG_MAJOR_VERSION 2
255
256 /* Now to separate file name parts.
257    Please note that the string version must not contain more
258    than one character because the code assumes strlen()==1 */
259 #ifdef HAVE_DOSISH_SYSTEM
260 #define DIRSEP_C '\\'
261 #define EXTSEP_C '.'
262 #define DIRSEP_S "\\"
263 #define EXTSEP_S "."
264 #else
265 #define DIRSEP_C '/'
266 #define EXTSEP_C '.'
267 #define DIRSEP_S "/"
268 #define EXTSEP_S "."
269 #endif
270
271 /* This is the same as VERSION, but should be overridden if the
272    platform cannot handle things like dots '.' in filenames. Set
273    SAFE_VERSION_DOT and SAFE_VERSION_DASH to whatever SAFE_VERSION
274    uses for dots and dashes. */
275 #define SAFE_VERSION VERSION
276 #define SAFE_VERSION_DOT  '.'
277 #define SAFE_VERSION_DASH '-'
278
279 /* For some systems (DOS currently), we hardcode the path here.  For
280    POSIX systems the values are constructed by the Makefiles, so that
281    the values may be overridden by the make invocations; this is to
282    comply with the GNU coding standards. */
283 #ifdef HAVE_DRIVE_LETTERS
284 #define GNUPG_BINDIR      "c:\\gnupg"
285 #define GNUPG_LIBEXECDIR  "c:\\lib\\gnupg"
286 #define GNUPG_LIBDIR      "c:\\lib\\gnupg"
287 #define GNUPG_DATADIR     "c:\\lib\\gnupg"
288 #endif
289
290 /* Setup the hardwired names of modules. */
291 #ifndef GNUPG_DEFAULT_AGENT
292 #define GNUPG_DEFAULT_AGENT    ( GNUPG_BINDIR DIRSEP_S "gpg-agent" )
293 #endif
294 #ifndef GNUPG_DEFAULT_PINENTRY
295 #define GNUPG_DEFAULT_PINENTRY ( GNUPG_BINDIR DIRSEP_S "pinentry" )
296 #endif
297 #ifndef GNUPG_DEFAULT_SCDAEMON
298 #define GNUPG_DEFAULT_SCDAEMON ( GNUPG_BINDIR DIRSEP_S "scdaemon" )
299 #endif
300 #ifndef GNUPG_DEFAULT_DIRMNGR
301 #define GNUPG_DEFAULT_DIRMNGR  ( GNUPG_BINDIR DIRSEP_S "dirmngr" )
302 #endif
303 #ifndef GNUPG_DEFAULT_PROTECT_TOOL
304 #define GNUPG_DEFAULT_PROTECT_TOOL \
305                     ( GNUPG_LIBEXECDIR DIRSEP_S "gpg-protect-tool" )
306 #endif
307
308
309 /* Derive some other constants. */
310 #if !(defined(HAVE_FORK) && defined(HAVE_PIPE) && defined(HAVE_WAITPID))
311 #define EXEC_TEMPFILE_ONLY
312 #endif
313
314 ])
315
316 AM_MAINTAINER_MODE
317
318 # Checks for programs.
319 AC_PROG_MAKE_SET
320 AM_SANITY_CHECK
321 missing_dir=`cd $ac_aux_dir && pwd`
322 AM_MISSING_PROG(ACLOCAL, aclocal, $missing_dir)
323 AM_MISSING_PROG(AUTOCONF, autoconf, $missing_dir)
324 AM_MISSING_PROG(AUTOMAKE, automake, $missing_dir)
325 AM_MISSING_PROG(AUTOHEADER, autoheader, $missing_dir)
326 AM_MISSING_PROG(MAKEINFO, makeinfo, $missing_dir)
327 AC_PROG_AWK
328 AC_PROG_CC
329 AC_PROG_CPP
330 AC_PROG_INSTALL
331 AC_PROG_LN_S
332 AC_PROG_MAKE_SET
333 AC_PROG_RANLIB
334 AC_CHECK_TOOL(AR, ar, :)
335 AC_PATH_PROG(PERL,"perl")
336 AC_ISC_POSIX
337 AC_SYS_LARGEFILE
338 AC_CHECK_PROG(DOCBOOK_TO_MAN, docbook-to-man, yes, no)
339 AM_CONDITIONAL(HAVE_DOCBOOK_TO_MAN, test "$ac_cv_prog_DOCBOOK_TO_MAN" = yes)
340 GNUPG_CHECK_FAQPROG
341 GNUPG_CHECK_DOCBOOK_TO_TEXI
342
343
344 try_gettext=yes
345 have_dosish_system=no
346 case "${target}" in
347     *-*-mingw32*)
348         # special stuff for Windoze NT
349         ac_cv_have_dev_random=no
350         AC_DEFINE(USE_ONLY_8DOT3,1,
351                   [set this to limit filenames to the 8.3 format])
352         AC_DEFINE(HAVE_DRIVE_LETTERS,1,
353                   [defined if we must run on a stupid file system])
354         AC_DEFINE(USE_SIMPLE_GETTEXT,1,
355                   [because the Unix gettext has too much overhead on
356                    MingW32 systems and these systems lack Posix functions,
357                    we use a simplified version of gettext])
358         have_dosish_system=yes
359         try_gettext="no"
360         ;;
361     i?86-emx-os2 | i?86-*-os2*emx )
362         # OS/2 with the EMX environment
363         ac_cv_have_dev_random=no
364         AC_DEFINE(HAVE_DRIVE_LETTERS)
365         have_dosish_system=yes
366         try_gettext="no"
367         ;;
368
369     i?86-*-msdosdjgpp*)
370         # DOS with the DJGPP environment
371         ac_cv_have_dev_random=no
372         AC_DEFINE(HAVE_DRIVE_LETTERS)
373         have_dosish_system=yes
374         try_gettext="no"
375         ;;
376
377     *-*-freebsd*)
378        # FreeBSD
379        CPPFLAGS="$CPPFLAGS -I/usr/local/include"
380        LDFLAGS="$LDFLAGS -L/usr/local/lib"
381        ;;
382
383     *-*-hpux*)
384         if test -z "$GCC" ; then
385             CFLAGS="$CFLAGS -Ae -D_HPUX_SOURCE"
386         fi
387         ;;
388     *-dec-osf4*)
389         if test -z "$GCC" ; then
390             # Suppress all warnings
391             # to get rid of the unsigned/signed char mismatch warnings.
392             CFLAGS="$CFLAGS -w"
393         fi
394         ;;
395     *-dec-osf5*)
396         if test -z "$GCC" ; then
397             # Use the newer compiler `-msg_disable ptrmismatch' to
398             # get rid of the unsigned/signed char mismatch warnings.
399             # Using this may hide other pointer mismatch warnings, but
400             # it at least lets other warning classes through
401             CFLAGS="$CFLAGS -msg_disable ptrmismatch"
402         fi
403         ;;
404     m68k-atari-mint)
405         ;;
406     *)
407        ;;
408 esac
409
410 if test "$have_dosish_system" = yes; then
411    AC_DEFINE(HAVE_DOSISH_SYSTEM,1,
412              [defined if we run on some of the PCDOS like systems 
413               (DOS, Windoze. OS/2) with special properties like
414               no file modes])
415 fi
416 AM_CONDITIONAL(HAVE_DOSISH_SYSTEM, test "$have_dosish_system" = yes)
417
418
419 #
420 # Checks for libraries.
421 #
422
423
424 #
425 # libgpg-error is a library with error codes shared between GnuPG
426 # related projects.
427 #
428 AM_PATH_GPG_ERROR("$NEED_GPG_ERROR_VERSION",
429                   have_gpg_error=yes,have_gpg_error=no)
430
431
432 #
433 # Libgcrypt is our generic crypto library
434 #
435 AM_PATH_LIBGCRYPT("$NEED_LIBGCRYPT_API:$NEED_LIBGCRYPT_VERSION",
436         have_libgcrypt=yes,have_libgcrypt=no)
437
438
439 #
440 # libassuan is used for IPC
441 #
442 AM_PATH_LIBASSUAN("$NEED_LIBASSUAN_VERSION",
443                   have_libassuan=yes,have_libassuan=no)
444
445
446 #
447 # libksba is our X.509 support library
448 #
449 AM_PATH_KSBA("$NEED_KSBA_VERSION",have_ksba=yes,have_ksba=no)
450
451 #
452 # libusb allows us to use the integrated CCID smartcard reader driver.
453 #
454 # Note, that we need the CVS version.  FIXME: libusb should have a
455 # regular check as the other libraries do.
456 #
457 AC_CHECK_LIB(usb, usb_find_device,
458               [ LIBUSB_LIBS="$LIBUSB_LIBS -lusb"
459                 AC_DEFINE(HAVE_LIBUSB,1,
460                          [defined if libusb is available])
461              ])
462 AC_SUBST(LIBUSB_LIBS)
463
464
465 #
466 # OpenSC is needed by the SCdaemon - if it is not availbale we can only
467 # build a limited SCdaemon
468 #
469 AM_PATH_OPENSC("$NEED_OPENSC_VERSION",have_opensc=yes,have_opensc=no)
470 if test $have_opensc = yes; then
471   AC_DEFINE(HAVE_OPENSC,1,
472             [defined if the OpenSC library is available])
473 fi
474 AM_CONDITIONAL(HAVE_OPENSC, test "$have_opensc" = "yes")
475
476 #
477 # Check whether the (highly desirable) GNU Pth library is available
478 #
479 AC_ARG_WITH(pth-prefix,
480             AC_HELP_STRING([--with-pth-prefix=PFX],
481                            [prefix where GNU Pth is installed (optional)]),
482      pth_config_prefix="$withval", pth_config_prefix="")
483 if test x$pth_config_prefix != x ; then
484    PTH_CONFIG="$pth_config_prefix/bin/pth-config"
485 fi
486 AC_PATH_PROG(PTH_CONFIG, pth-config, no)
487 if test "$PTH_CONFIG" = "no"; then
488     AC_MSG_WARN([[
489 ***
490 *** To support concurrent access to the gpg-agent and the SCdaemon
491 *** we need the support of the GNU Portable Threads Library.
492 *** Download it from ftp://ftp.gnu.org/gnu/pth/
493 *** On a Debian GNU/Linux system you might want to try 
494 ***   apt-get install libpth-dev
495 ***]])
496 else
497   GNUPG_PTH_VERSION_CHECK(1.3.7)
498   if test $have_pth = yes; then      
499      PTH_CFLAGS=`$PTH_CONFIG --cflags`
500      PTH_LIBS=`$PTH_CONFIG --ldflags`
501      PTH_LIBS="$PTH_LIBS `$PTH_CONFIG --libs`"
502      AC_DEFINE(USE_GNU_PTH, 1,
503               [Defined if the GNU Portable Thread Library should be used])
504   fi
505 fi
506 AC_SUBST(PTH_CFLAGS)
507 AC_SUBST(PTH_LIBS)
508
509 AC_ARG_ENABLE(threads,
510     AC_HELP_STRING([--disable-threads],[allow building without Pth support]);
511     
512 )
513
514
515 dnl Must check for network library requirements before doing link tests
516 dnl for ldap, for example. If ldap libs are static (or dynamic and without
517 dnl ELF runtime link paths), then link will fail and LDAP support won't
518 dnl be detected.
519
520 AC_CHECK_FUNC(gethostbyname, , AC_CHECK_LIB(nsl, gethostbyname,
521         [NETLIBS="-lnsl $NETLIBS"]))
522 AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt,
523         [NETLIBS="-lsocket $NETLIBS"]))
524
525 dnl Now try for the resolver functions so we can use DNS SRV
526
527 AC_ARG_ENABLE(dns-srv,
528    AC_HELP_STRING([--disable-dns-srv],[disable the use of DNS SRV in HKP]),
529    use_dns_srv=$enableval,use_dns_srv=yes)
530
531 if test x"$try_hkp" = xyes && test x"$use_dns_srv" = xyes ; then
532   _srv_save_libs=$LIBS
533   LIBS=""
534   # the double underscore thing is a glibc-ism?
535   AC_SEARCH_LIBS(res_query,resolv bind,,
536                  AC_SEARCH_LIBS(__res_query,resolv bind,,use_dns_srv=no))
537   AC_SEARCH_LIBS(dn_expand,resolv bind,,
538                  AC_SEARCH_LIBS(__dn_expand,resolv bind,,use_dns_srv=no))
539   AC_SEARCH_LIBS(dn_skipname,resolv bind,,
540                  AC_SEARCH_LIBS(__dn_skipname,resolv bind,,use_dns_srv=no))
541
542   if test x"$use_dns_srv" = xyes ; then
543      AC_DEFINE(USE_DNS_SRV,1,[define to use DNS SRV])
544      SRVLIBS=$LIBS
545   else
546      AC_MSG_WARN([Resolver functions not found.  Disabling DNS SRV.])
547   fi
548   LIBS=$_srv_save_libs
549 fi
550
551 AC_SUBST(SRVLIBS)
552
553 # Try and link a LDAP test program to weed out unusable LDAP
554 # libraries.  -lldap [-llber [-lresolv]] is for OpenLDAP.  OpenLDAP in
555 # general is terrible with creating weird dependencies.  If all else
556 # fails, the user can play guess-the-dependency by using something
557 # like ./configure LDAPLIBS="-Lfoo -lbar"
558
559 if test "$try_ldap" = yes ; then
560   for MY_LDAPLIBS in ${LDAPLIBS+"$LDAPLIBS"} "-lldap" "-lldap -llber" "-lldap -llber -lresolv"; do
561     _ldap_save_libs=$LIBS
562     LIBS="$MY_LDAPLIBS $NETLIBS $LIBS"
563
564     AC_MSG_CHECKING([whether LDAP via \"$MY_LDAPLIBS\" is present and sane])
565     AC_TRY_LINK([#include <ldap.h>],[ldap_open("foobar",1234);],
566                 [gnupg_cv_func_ldap_init=yes],[gnupg_cv_func_ldap_init=no])
567     AC_MSG_RESULT([$gnupg_cv_func_ldap_init])
568
569     if test $gnupg_cv_func_ldap_init = no; then
570       AC_MSG_CHECKING([whether I can make LDAP be sane with lber.h])
571       AC_TRY_LINK([#include <lber.h>
572 #include <ldap.h>],[ldap_open("foobar",1234);],
573          [gnupg_cv_func_ldaplber_init=yes],[gnupg_cv_func_ldaplber_init=no])
574       AC_MSG_RESULT([$gnupg_cv_func_ldaplber_init])
575     fi
576
577     if test "$gnupg_cv_func_ldaplber_init" = yes ; then
578        AC_DEFINE(NEED_LBER_H,1,[Define if the LDAP library requires including lber.h before ldap.h])
579     fi
580
581     if test "$gnupg_cv_func_ldap_init" = yes || \
582         test "$gnupg_cv_func_ldaplber_init" = yes ; then
583        LDAPLIBS=$MY_LDAPLIBS
584        GPGKEYS_LDAP="gpgkeys_ldap$EXEEXT"
585
586        AC_MSG_CHECKING([whether LDAP supports ldap_get_option])
587
588        if test "$gnupg_cv_func_ldap_init" = yes ; then
589           AC_TRY_LINK([#include <ldap.h>],
590              [ldap_get_option((void *)0,0,(void *)0);],
591              [gnupg_cv_func_ldap_get_option=yes],
592              [gnupg_cv_func_ldap_get_option=no])
593         else
594           AC_TRY_LINK([#include <lber.h>
595 #include <ldap.h>],[ldap_get_option((void *)0,0,(void *)0);],
596              [gnupg_cv_func_ldap_get_option=yes],
597              [gnupg_cv_func_ldap_get_option=no])
598        fi
599
600        AC_MSG_RESULT([$gnupg_cv_func_ldap_get_option])
601
602        if test "$gnupg_cv_func_ldap_get_option" = yes ; then
603           AC_DEFINE(HAVE_LDAP_GET_OPTION,1,[Define if the LDAP library has ldap_get_option])
604        else
605           AC_MSG_CHECKING([whether LDAP supports ld_errno])
606
607           if test "$gnupg_cv_func_ldap_init" = yes ; then
608             AC_TRY_COMPILE([#include <ldap.h>],
609                [LDAP *ldap; ldap->ld_errno;],
610                [gnupg_cv_func_ldap_ld_errno=yes],
611                [gnupg_cv_func_ldap_ld_errno=no])
612            else
613             AC_TRY_LINK([#include <lber.h>
614 #include <ldap.h>],[LDAP *ldap; ldap->ld_errno;],
615                [gnupg_cv_func_ldap_ld_errno=yes],
616                [gnupg_cv_func_ldap_ld_errno=no])
617           fi
618
619           AC_MSG_RESULT([$gnupg_cv_func_ldap_ld_errno])
620
621           if test "$gnupg_cv_func_ldap_ld_errno" = yes ; then
622              AC_DEFINE(HAVE_LDAP_LD_ERRNO,1,[Define if the LDAP library supports ld_errno])
623           fi
624        fi
625     fi
626
627     LIBS=$_ldap_save_libs
628
629     if test "$GPGKEYS_LDAP" != "" ; then break; fi
630   done
631 fi
632
633 AC_SUBST(GPGKEYS_LDAP)
634 AC_SUBST(LDAPLIBS)
635
636 dnl This isn't necessarily sendmail itself, but anything that gives a
637 dnl sendmail-ish interface to the outside world.  That includes qmail,
638 dnl postfix, etc.  Basically, anything that can handle "sendmail -t".
639
640 if test "$try_mailto" = yes ; then
641   AC_ARG_WITH(mailprog,[  --with-mailprog=NAME    use "NAME -t" for mail transport],,with_mailprog=yes)
642
643   if test "$with_mailprog" = yes ; then
644     AC_PATH_PROG(SENDMAIL,sendmail,,$PATH:/usr/sbin:/usr/libexec:/usr/lib)
645     if test "$ac_cv_path_SENDMAIL" ; then
646       GPGKEYS_MAILTO="gpgkeys_mailto"
647     fi
648   elif test "$with_mailprog" != no ; then
649     AC_MSG_CHECKING([for a mail transport program])
650     AC_SUBST(SENDMAIL,$with_mailprog)
651     AC_MSG_RESULT($with_mailprog)
652     GPGKEYS_MAILTO="gpgkeys_mailto"
653   fi
654 fi
655
656 AC_SUBST(GPGKEYS_MAILTO)
657
658 case "${target}" in
659     *-*-mingw32*)
660         PRINTABLE_OS_NAME="MingW32"
661         ;;
662     *-*-cygwin*)
663         PRINTABLE_OS_NAME="Cygwin"
664         ;;
665     i?86-emx-os2 | i?86-*-os2*emx )
666         PRINTABLE_OS_NAME="OS/2"
667         ;;
668     i?86-*-msdosdjgpp*)
669         PRINTABLE_OS_NAME="MSDOS/DJGPP"
670         try_dynload=no
671         ;;
672     *-linux*)
673         PRINTABLE_OS_NAME="GNU/Linux"
674         ;;
675     *)
676         PRINTABLE_OS_NAME=`uname -s || echo "Unknown"`
677         ;;
678 esac
679 AC_DEFINE_UNQUOTED(PRINTABLE_OS_NAME, "$PRINTABLE_OS_NAME",
680                    [A human readable text with the name of the OS])
681
682
683 AM_GNU_GETTEXT_VERSION(0.12.1)
684 if test "$try_gettext" = yes; then
685   AM_GNU_GETTEXT(,[need-ngettext])
686
687   # gettext requires some extra checks.  These really should be part of
688   # the basic AM_GNU_GETTEXT macro.  TODO: move other gettext-specific
689   # function checks to here.
690
691   AC_CHECK_FUNCS(strchr)
692 else
693   USE_NLS=no
694   USE_INCLUDED_LIBINTL=no
695   BUILD_INCLUDED_LIBINTL=no
696   AC_SUBST(USE_NLS)
697   AC_SUBST(USE_INCLUDED_LIBINTL)
698   AC_SUBST(BUILD_INCLUDED_LIBINTL)
699 fi
700
701 # Checks for header files.
702 AC_HEADER_STDC
703 AC_CHECK_HEADERS(string.h unistd.h langinfo.h termio.h locale.h)
704
705 # Checks for typedefs, structures, and compiler characteristics.
706 AC_C_CONST
707 AC_C_INLINE
708 AC_TYPE_SIZE_T
709 AC_TYPE_SIGNAL
710 AC_DECL_SYS_SIGLIST
711
712 GNUPG_CHECK_ENDIAN
713
714 GNUPG_CHECK_TYPEDEF(byte, HAVE_BYTE_TYPEDEF)
715 GNUPG_CHECK_TYPEDEF(ushort, HAVE_USHORT_TYPEDEF)
716 GNUPG_CHECK_TYPEDEF(ulong, HAVE_ULONG_TYPEDEF)
717 GNUPG_CHECK_TYPEDEF(u16, HAVE_U16_TYPEDEF)
718 GNUPG_CHECK_TYPEDEF(u32, HAVE_U32_TYPEDEF)
719
720 AC_CHECK_SIZEOF(unsigned short)
721 AC_CHECK_SIZEOF(unsigned int)
722 AC_CHECK_SIZEOF(unsigned long)
723 AC_CHECK_SIZEOF(unsigned long long)
724 # Ensure that we have UINT64_C before we bother to check for uint64_t
725 # fixme: really needed in gnupg?  I think it is only useful in libcgrypt.
726 AC_CACHE_CHECK([for UINT64_C],[gnupg_cv_uint64_c_works],
727    AC_COMPILE_IFELSE(AC_LANG_PROGRAM([#include <inttypes.h>
728 uint64_t foo=UINT64_C(42);]),gnupg_cv_uint64_c_works=yes,gnupg_cv_uint64_c_works=no))
729 if test "$gnupg_cv_uint64_c_works" = "yes" ; then
730    AC_CHECK_SIZEOF(uint64_t)
731 fi
732  
733
734
735
736 if test "$ac_cv_sizeof_unsigned_short" = "0" \
737    || test "$ac_cv_sizeof_unsigned_int" = "0" \
738    || test "$ac_cv_sizeof_unsigned_long" = "0"; then
739     AC_MSG_WARN([Hmmm, something is wrong with the sizes - using defaults]);
740 fi
741
742 dnl Do we have any 64-bit data types?
743 if test "$ac_cv_sizeof_unsigned_int" != "8" \
744    && test "$ac_cv_sizeof_unsigned_long" != "8" \
745    && test "$ac_cv_sizeof_unsigned_long_long" != "8" \
746    && test "$ac_cv_sizeof_uint64_t" != "8"; then
747     AC_MSG_WARN([No 64-bit types.  Disabling SHA-384, and SHA-512])
748 else
749   if test x"$use_sha512" = xyes ; then
750      AC_SUBST(SHA512_O,sha512.o)
751      AC_DEFINE(USE_SHA512,1,[Define to include the SHA-384 and SHA-512 digests])
752   fi
753 fi
754
755 # fixme: do we really need this - it should be encapsulated in libassuan
756 GNUPG_SYS_SO_PEERCRED
757
758 # Checks for library functions.
759 AC_FUNC_FSEEKO
760 AC_FUNC_VPRINTF
761 AC_FUNC_FORK
762 AC_CHECK_FUNCS(strerror stpcpy strsep strlwr tcgetattr strtoul mmap)
763 AC_CHECK_FUNCS(strcasecmp strncasecmp ctermid times gmtime_r)
764 AC_CHECK_FUNCS(memmove gettimeofday getrusage setrlimit clock_gettime)
765 AC_CHECK_FUNCS(atexit raise getpagesize strftime nl_langinfo setlocale)
766 AC_CHECK_FUNCS(waitpid wait4 sigaction sigprocmask rand pipe stat getaddrinfo)
767
768 AC_CHECK_TYPES([struct sigaction, sigset_t],,,[#include <signal.h>])
769
770 # These are needed by libjnlib - fixme: we should have macros for them
771 AC_CHECK_FUNCS(memicmp stpcpy strlwr strtoul memmove stricmp strtol)
772 AC_CHECK_FUNCS(getrusage setrlimit stat setlocale)
773 AC_CHECK_FUNCS(flockfile funlockfile fopencookie funopen)
774
775 AC_REPLACE_FUNCS(vasprintf)
776 AC_REPLACE_FUNCS(mkdtemp)
777 AC_REPLACE_FUNCS(fseeko ftello)
778 AC_REPLACE_FUNCS(isascii)
779 AC_REPLACE_FUNCS(putc_unlocked)
780
781
782
783
784 #
785 # check for gethrtime and run a testprogram to see whether
786 # it is broken.  It has been reported that some Solaris and HP UX systems 
787 # raise an SIGILL
788 #
789 #  fixme: Do we need this - iirc, this is only used by libgcrypt.
790 #
791 AC_CACHE_CHECK([for gethrtime], 
792                [gnupg_cv_func_gethrtime],
793                [AC_TRY_LINK([#include <sys/times.h>],[
794                    hrtime_t tv;
795                    tv = gethrtime();
796                  ],
797                  [gnupg_cv_func_gethrtime=yes],
798                  [gnupg_cv_func_gethrtime=no])
799                ])
800 if test $gnupg_cv_func_gethrtime = yes; then
801      AC_DEFINE([HAVE_GETHRTIME], 1,
802                [Define if you have the `gethrtime(2)' function.])
803      AC_CACHE_CHECK([whether gethrtime is broken], 
804                [gnupg_cv_func_broken_gethrtime],
805                [AC_TRY_RUN([
806                    #include <sys/times.h>
807                    int main () {
808                    hrtime_t tv;
809                    tv = gethrtime(); 
810                  }
811                  ],
812                  [gnupg_cv_func_broken_gethrtime=no],
813                  [gnupg_cv_func_broken_gethrtime=yes],
814                  [gnupg_cv_func_broken_gethrtime=assume-no])
815                 ])
816     if test $gnupg_cv_func_broken_gethrtime = yes; then
817       AC_DEFINE([HAVE_BROKEN_GETHRTIME], 1,
818       [Define if `gethrtime(2)' does not work correctly i.e. issues a SIGILL.])
819     fi
820 fi
821      
822
823 GNUPG_CHECK_MLOCK
824 GNUPG_FUNC_MKDIR_TAKES_ONE_ARG
825
826 dnl
827 dnl Check whether we can use Linux capabilities as requested
828 dnl
829 #  fixme: Still required?
830 #
831 if test "$use_capabilities" = "yes" ; then
832 use_capabilities=no
833 AC_CHECK_HEADERS(sys/capability.h)
834 if test "$ac_cv_header_sys_capability_h" = "yes" ; then
835   AC_CHECK_LIB(cap, cap_init, ac_need_libcap=1)
836   if test "$ac_cv_lib_cap_cap_init" = "yes"; then
837      AC_DEFINE(USE_CAPABILITIES,1,
838                [define if capabilities should be used])
839      AC_SUBST(CAPLIBS,"-lcap")
840      use_capabilities=yes
841   fi
842 fi
843 if test "$use_capabilities" = "no" ; then
844     AC_MSG_WARN([[
845 ***
846 *** The use of capabilities on this system is not possible.
847 *** You need a recent Linux kernel and some patches:
848 ***   fcaps-2.2.9-990610.patch      (kernel patch for 2.2.9)
849 ***   fcap-module-990613.tar.gz     (kernel module)
850 ***   libcap-1.92.tar.gz            (user mode library and utilities)
851 *** And you have to configure the kernel with CONFIG_VFS_CAP_PLUGIN
852 *** set (filesystems menu). Be warned: This code is *really* ALPHA.
853 ***]])
854 fi
855 fi
856
857
858 # Sanity check regex.  Tests adapted from mutt.
859
860 AC_MSG_CHECKING([whether regular expression support is requested])
861 AC_ARG_ENABLE(regex,
862 [  --disable-regex         do not handle regular expressions in trust sigs],
863      use_regex=$enableval, use_regex=yes)
864 AC_MSG_RESULT($use_regex)
865
866 if test "$use_regex" = yes ; then
867   AC_MSG_CHECKING([whether the included regex lib is requested])
868   AC_ARG_WITH(included-regex,
869       [  --with-included-regex   use the included GNU regex library],
870       [gnupg_cv_included_regex=yes],[gnupg_cv_included_regex=no])
871   AC_MSG_RESULT($gnupg_cv_included_regex)
872
873   if test $gnupg_cv_included_regex = no ; then
874      # Does the system have regex functions at all?
875      AC_CHECK_FUNC(regcomp,gnupg_cv_included_regex=no,
876                            gnupg_cv_included_regex=yes)
877   fi
878
879   if test $gnupg_cv_included_regex = no ; then
880      AC_CACHE_CHECK([whether your system's regexp library is broken],
881        [gnupg_cv_regex_broken],
882        AC_TRY_RUN([
883 #include <unistd.h>
884 #include <regex.h>
885 main() { regex_t blah ; regmatch_t p; p.rm_eo = p.rm_eo; return regcomp(&blah, "foo.*bar", REG_NOSUB) || regexec (&blah, "foobar", 0, NULL, 0); }],
886        gnupg_cv_regex_broken=no, gnupg_cv_regex_broken=yes, gnupg_cv_regex_broken=yes))
887
888      if test $gnupg_cv_regex_broken = yes ; then
889       AC_MSG_WARN(your regex is broken - using the included GNU regex instead.)
890       gnupg_cv_included_regex=yes
891      fi
892   fi
893
894   if test $gnupg_cv_included_regex = yes; then
895      AC_DEFINE(USE_GNU_REGEX,1,[ Define if you want to use the included regex lib ])
896      AC_SUBST(REGEX_O,regex.o)
897   fi
898 else
899
900   AC_DEFINE(DISABLE_REGEX,1,[ Define to disable regular expression support ])
901 fi
902
903 dnl Do we have zlib? Must do it here because Solaris failed
904 dnl when compiling a conftest (due to the "-lz" from LIBS).
905 use_local_zlib=yes
906 if test "$g10_force_zlib" = "yes"; then
907   :
908 else
909   _cppflags="${CPPFLAGS}"
910   _ldflags="${LDFLAGS}"
911
912   AC_ARG_WITH(zlib,
913   [  --with-zlib=DIR         use libz in DIR],[
914     if test -d "$withval"; then
915       CPPFLAGS="${CPPFLAGS} -I$withval/include"
916       LDFLAGS="${LDFLAGS} -L$withval/lib"
917     fi
918   ])
919
920   AC_CHECK_HEADER(zlib.h,
921       AC_CHECK_LIB(z, deflateInit2_,
922        use_local_zlib=no
923        LIBS="$LIBS -lz",
924        CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags}),
925        CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags})
926 fi
927  
928 if test "$use_local_zlib" = yes ; then
929     AM_CONDITIONAL(ENABLE_LOCAL_ZLIB, true)
930     AC_CONFIG_LINKS(zlib.h:zlib/zlib.h zconf.h:zlib/zconf.h )
931     ZLIBS="../zlib/libzlib.a"
932 else
933     AM_CONDITIONAL(ENABLE_LOCAL_ZLIB, false)
934     ZLIBS=
935 fi
936 AC_SUBST(ZLIBS)
937
938 # Allow users to append something to the version string without
939 # flagging it as development version.  The user version parts is
940 # considered everything after a dash. 
941 if test "$development_version" != yes; then
942   changequote(,)dnl
943   tmp_pat='[a-zA-Z]'
944   changequote([,])dnl
945   if echo "$VERSION" | sed 's/-.*//' | grep "$tmp_pat" >/dev/null ; then
946     development_version=yes
947   fi
948 fi
949 if test "$development_version" = yes; then
950     AC_DEFINE(IS_DEVELOPMENT_VERSION,1,
951             [Defined if this is not a regular release])
952 fi
953
954 AM_CONDITIONAL(CROSS_COMPILING, test x$cross_compiling = xyes)
955
956 GNUPG_CHECK_GNUMAKE
957
958 # add some extra libs here so that previous tests don't fail for
959 # mysterious reasons - the final link step should bail out. 
960 case "${target}" in
961     *-*-mingw32*)
962         W32LIBS="-lwsock32"
963         ;;
964     *)
965        ;;
966 esac
967
968
969 if test "$GCC" = yes; then
970     if test "$USE_MAINTAINER_MODE" = "yes"; then
971         CFLAGS="$CFLAGS -Wall -Wcast-align -Wshadow -Wstrict-prototypes"
972         CFLAGS="$CFLAGS -Wformat-nonliteral"
973     else
974         CFLAGS="$CFLAGS -Wall"
975     fi
976 fi
977
978 AC_SUBST(NETLIBS)
979 AC_SUBST(W32LIBS)
980
981
982 # We use jnlib, so tell other modules about it
983 AC_DEFINE(HAVE_JNLIB_LOGGING, 1,
984           [Defined if jnlib style logging functions are available])
985
986
987
988 #
989 # Decide what to build
990 #
991 missing_pth=no
992 if test $have_ksba = no; then
993   build_gpgsm=no
994   build_scdaemon=no
995 fi
996
997 build_agent_threaded=""
998 if test "$build_agent" = "yes"; then
999   if test $have_pth = no; then
1000      build_agent_threaded="(not multi-threaded)"
1001      missing_pth=yes
1002   fi
1003 fi
1004
1005 build_scdaemon_extra=""
1006 if test "$build_scdaemon" = "yes"; then
1007   tmp=""
1008   if test $have_pth = no; then
1009      build_scdaemon_extra="not multi-threaded"
1010      tmp=", "
1011      missing_pth=yes
1012   fi
1013   if test $have_opensc = no; then
1014      build_scdaemon_extra="${build_scdaemon_extra}${tmp}no pkcs#15"
1015      tmp=", "
1016   fi      
1017   if test -n "$build_scdaemon_extra"; then
1018      build_scdaemon_extra="(${build_scdaemon_extra})"
1019   fi
1020 fi
1021
1022 if test "$build_agent_only" = "yes" ; then
1023   build_gpg=no
1024   build_gpgsm=no
1025   build_scdaemon=no
1026 fi
1027
1028 AM_CONDITIONAL(BUILD_GPG,   test "$build_gpg" = "yes")
1029 AM_CONDITIONAL(BUILD_GPGSM, test "$build_gpgsm" = "yes")
1030 AM_CONDITIONAL(BUILD_AGENT, test "$build_agent" = "yes")
1031 AM_CONDITIONAL(BUILD_SCDAEMON, test "$build_scdaemon" = "yes")
1032
1033
1034
1035 #
1036 # Print errors here so that they are visible all
1037 # together and the user can acquire them all together.
1038 #
1039 die=no
1040 if test "$have_gpg_error" = "no"; then
1041    die=yes
1042    AC_MSG_NOTICE([[
1043 ***  
1044 *** You need libgpg-error to build this program.
1045 **  This library is for example available at
1046 ***   ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error
1047 *** (at least version $NEED_GPG_ERROR_VERSION is required.)
1048 ***]])
1049 fi
1050 if test "$have_libgcrypt" = "no"; then
1051    die=yes
1052    AC_MSG_NOTICE([[
1053 ***  
1054 *** You need libgcrypt to build this program.
1055 **  This library is for example available at
1056 ***   ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/
1057 *** (at least version $NEED_LIBGCRYPT_VERSION using API $NEED_LIBGCRYPT_API) is required.)
1058 ***]])
1059 fi
1060 if test "$have_libassuan" = "no"; then
1061    die=yes
1062    AC_MSG_NOTICE([[
1063 ***
1064 *** You need libassuan to build this program.
1065 *** This library is for example available at
1066 ***   ftp://ftp.gnupg.org/gcrypt/alpha/libassuan/
1067 *** (at least version $NEED_LIBASSUAN_VERSION is required).
1068 ***]])
1069 fi
1070 if test "$have_ksba" = "no"; then
1071     AC_MSG_NOTICE([[
1072 ***
1073 *** You need libksba to build this program.
1074 *** This library is for example available at
1075 ***   ftp://ftp.gnupg.org/gcrypt/alpha/libksba/
1076 *** (at least version $NEED_KSBA_VERSION is required).
1077 ***]])
1078 fi
1079 if test "$missing_pth" = "yes"; then
1080     AC_MSG_NOTICE([[
1081 ***
1082 *** It is strongly suggested to build with support for the
1083 *** GNU Portable Threads Library (Pth). Please install this
1084 *** library first or use --disable-threads to allow building
1085 *** anyway.  The library is for example available at
1086 ***   ftp://ftp.gnu.org/gnu/pth/
1087 *** On a Debian GNU/Linux system you can install it using 
1088 ***   apt-get install libpth-dev
1089 ***]])
1090   if test "$enable_threads" != "no"; then
1091      die=yes
1092   fi
1093 fi
1094
1095 if test "$die" = "yes"; then
1096     AC_MSG_ERROR([[
1097 ***
1098 *** Required libraries not found. Please consult the above messages
1099 *** and install them before running configure again.
1100 ***]])
1101 fi
1102
1103
1104
1105 AC_CONFIG_FILES([ m4/Makefile 
1106 Makefile
1107 po/Makefile.in
1108 intl/Makefile
1109 jnlib/Makefile
1110 common/Makefile
1111 kbx/Makefile
1112 g10/Makefile
1113 sm/Makefile
1114 agent/Makefile
1115 scd/Makefile
1116 tools/Makefile
1117 doc/Makefile
1118 tests/Makefile
1119 ])
1120 AC_OUTPUT
1121
1122
1123
1124
1125 echo "
1126         GnuPG v${VERSION} has been configured as follows:
1127         
1128         Platform:  $PRINTABLE_OS_NAME ($target)
1129
1130         OpenPGP:   $build_gpg
1131         S/MIME:    $build_gpgsm
1132         Agent:     $build_agent $build_agent_threaded
1133         Smartcard: $build_scdaemon $build_scdaemon_extra
1134
1135         Protect tool:     $show_gnupg_protect_tool_pgm
1136         Default agent:    $show_gnupg_agent_pgm
1137         Default pinentry: $show_gnupg_pinentry_pgm
1138         Default scdaemon: $show_gnupg_scdaemon_pgm
1139         Default dirmngr:  $show_gnupg_dirmngr_pgm
1140 "
1141