Add executable flag to test scripts.
[gnupg.git] / TODO
diff --git a/TODO b/TODO
index 7b1c1cf..c1392db 100644 (file)
--- a/TODO
+++ b/TODO
@@ -23,7 +23,6 @@
 ** mark all unimplemented commands and options.
 ** Implement --default-key
 ** support the anyPolicy semantic
-** Check that we are really following the verification procedures in rfc3280.
 
 
 * sm/keydb.c
   not a real problem because application will get a card removed
   status and should the send a reset to try solving the problem.
 
-** Add a test to check the extkeyusage.
+** Add a regression test to check the extkeyusage.
 
 * Windows port (W32)
 ** No card status notifications.
 ** Regex support is disabled
   We need to adjust the test to find the regex we have anyway in 
-  gpg4in.  Is that regex compatible to the OpenPGP requirement?
+  gpg4win.  Is that regex compatible to the OpenPGP requirement?
 
 
 * sm/
@@ -91,7 +90,7 @@
 ** issue a NO_SECKEY xxxx if a -u key was not found.
 
 
-* When switching to libgcrypt 1.3
+* When switching to libgcrypt 1.4
 ** scd#encode_md_for_card, g10#encode_md_value, sm@do_encode_md
    Remove the extra test for a valid algorithm as libgcrypt will do it
    then in gcry_md_algo_info.
 * Remove -sat PGP2 compatibility hack
 
 * UTF-8 specific TODOs
+  None.
 
 * Pinpad Reader
   We do not yet support P15 applications.  The trivial thing using
 * Howtos
 ** Migrate OpenPGP keys to another system
 
+* Gpg-Agent Locale
+  Although we pass LC_MESSAGE from gpgsm et al. to Pinentry, this has
+  only an effect on the stock GTK strings (e.g. "OK") and not on any
+  strings gpg-agent generates and passes to Pinentry.  This defeats
+  our design goal to allow changing the locale without changing
+  gpg-agent's default locale (e.g. by the command updatestartuptty).
 
-* do_add_recipient 
- Prints wrong error message even when decrypting.
- *Decrypt* does even not work in this case.
 
-* Duplicate certifciates
-  This may happen and lead to an Ambiguous Name error.  Solution is to
-  check the certs for identity beforethorwin this error.