wks: Do not use compression for the encrypted data.
authorWerner Koch <wk@gnupg.org>
Tue, 18 Dec 2018 07:21:03 +0000 (08:21 +0100)
committerWerner Koch <wk@gnupg.org>
Tue, 18 Dec 2018 07:21:03 +0000 (08:21 +0100)
commit70a8db0333e3c22403b3647f8b5f924f6dace719
treebb1d7ee23167dfa0fc65fb8a5ae6153981c9db2c
parente6b7e0ff9990813ac9f11b2d9d92596d6379ebfe
wks: Do not use compression for the encrypted data.

* tools/gpg-wks-client.c (encrypt_response): Add arg -z0.
* tools/gpg-wks-server.c (encrypt_stream): Ditto.
--

If for example a server was built without the development packages of
the compression libraries installed, the server will not be able to
decrypt a request.  In theory this can't happen due to the preference
system but it is just to easy to create the server's key using a
different version of gpg and then use gpg-wks-server built
differently.

For the short messages we exchange compression is not really required
and thus we better do without to make the system more robust.

Signed-off-by: Werner Koch <wk@gnupg.org>
tools/gpg-wks-client.c
tools/gpg-wks-server.c