* gpg.sgml: Reminders that --cipher-algo, --digest-algo, and
authorDavid Shaw <dshaw@jabberwocky.com>
Wed, 19 Apr 2006 03:56:23 +0000 (03:56 +0000)
committerDavid Shaw <dshaw@jabberwocky.com>
Wed, 19 Apr 2006 03:56:23 +0000 (03:56 +0000)
--compress-algo should be avoided.

doc/ChangeLog
doc/gpg.sgml

index c0a640e..1bdea86 100644 (file)
@@ -1,3 +1,8 @@
+2006-04-18  David Shaw  <dshaw@jabberwocky.com>
+
+       * gpg.sgml: Reminders that --cipher-algo, --digest-algo, and
+       --compress-algo should be avoided.
+
 2006-04-11  Michael Roth <mroth@nessie.de>  (wk)
 
        * gpg.sgml (passphrase-fd): Explain that only the first line is used.
index 297f6c9..f365c3c 100644 (file)
@@ -2159,10 +2159,13 @@ Maximum depth of a certification chain (default is 5).
 <varlistentry>
 <term>--cipher-algo &ParmName;</term>
 <listitem><para>
-Use  &ParmName; as cipher algorithm. Running the program
-with the command --version yields a list of supported
-algorithms. If this is not used the cipher algorithm is
-selected from the preferences stored with the key.
+Use &ParmName; as cipher algorithm. Running the program with the
+command --version yields a list of supported algorithms.  If this is
+not used the cipher algorithm is selected from the preferences stored
+with the key.  In general, you do not want to use this option as it
+allows you to violate the OpenPGP standard.
+--personal-cipher-preferences is the safe way to accomplish the same
+thing.
 </para></listitem></varlistentry>
 
 
@@ -2170,7 +2173,10 @@ selected from the preferences stored with the key.
 <term>--digest-algo &ParmName;</term>
 <listitem><para>
 Use &ParmName; as the message digest algorithm. Running the program
-with the command --version yields a list of supported algorithms.
+with the command --version yields a list of supported algorithms.  In
+general, you do not want to use this option as it allows you to
+violate the OpenPGP standard.  --personal-digest-preferences is the
+safe way to accomplish the same thing.
 </para></listitem></varlistentry>
 
 
@@ -2193,7 +2199,10 @@ compression results than that, but will use a significantly larger
 amount of memory while compressing and decompressing.  This may be
 significant in low memory situations.  Note, however, that PGP (all
 versions) only supports ZIP compression.  Using any algorithm other
-than ZIP or "none" will make the message unreadable with PGP.
+than ZIP or "none" will make the message unreadable with PGP.  In
+general, you do not want to use this option as it allows you to
+violate the OpenPGP standard.  --personal-compress-preferences is the
+safe way to accomplish the same thing.
 </para></listitem></varlistentry>