gpg: Start using OCB mode by default with Libgcrypt 1.9.
authorWerner Koch <wk@gnupg.org>
Fri, 16 Nov 2018 08:19:10 +0000 (09:19 +0100)
committerWerner Koch <wk@gnupg.org>
Fri, 16 Nov 2018 08:19:10 +0000 (09:19 +0100)
* g10/main.h (GCRYPT_VERSION_NUMBER): Fix type in condition.
--

GnuPG-bug-id: 4259
Signed-off-by: Werner Koch <wk@gnupg.org>
g10/main.h

index 768f7cf..86f8589 100644 (file)
@@ -41,7 +41,9 @@
 # define DEFAULT_CIPHER_ALGO     CIPHER_ALGO_3DES
 #endif
 
-#if GCRYPT_VERSION_NUMBER < 0x019000
+/* We will start using OCB mode by default only if the yet to be
+ * released libgcrypt 1.9 is used.  */
+#if GCRYPT_VERSION_NUMBER < 0x010900
 # define DEFAULT_AEAD_ALGO  AEAD_ALGO_OCB
 #else
 # define DEFAULT_AEAD_ALGO  AEAD_ALGO_EAX