gpg: Silence "packet with obsolete versoin" warnings.
authorWerner Koch <wk@gnupg.org>
Sun, 19 Oct 2014 12:17:23 +0000 (14:17 +0200)
committerWerner Koch <wk@gnupg.org>
Sun, 19 Oct 2014 12:17:23 +0000 (14:17 +0200)
* g10/parse-packet.c (parse_key): Print warning only in very verbose
mode.

Signed-off-by: Werner Koch <wk@gnupg.org>
g10/parse-packet.c

index 50da17c..7787825 100644 (file)
@@ -1949,7 +1949,8 @@ parse_key (IOBUF inp, int pkttype, unsigned long pktlen,
     }
   else if (version == 2 || version == 3)
     {
-      log_info ("packet(%d) with obsolete version %d\n", pkttype, version);
+      if (opt.verbose > 1)
+        log_info ("packet(%d) with obsolete version %d\n", pkttype, version);
       if (list_mode)
         es_fprintf (listfp, ":key packet: [obsolete version %d]\n", version);
       err = gpg_error (GPG_ERR_INV_PACKET);