speedo: Check that wget and gpgv are installed.
authorWerner Koch <wk@gnupg.org>
Thu, 18 Sep 2014 14:00:34 +0000 (16:00 +0200)
committerWerner Koch <wk@gnupg.org>
Mon, 22 Sep 2014 12:38:55 +0000 (14:38 +0200)
* build-aux/getswdb.sh: Check for required tools.

build-aux/getswdb.sh

index cef6c46..a7796e2 100755 (executable)
@@ -94,6 +94,12 @@ fi
 version=$(cat "$srcdir/../VERSION")
 version_num=$(echo "$version" | cvtver)
 
+if ! $GPGV --version >/dev/null 2>/dev/null ; then
+  echo "command \"gpgv\" is not installed" >&2
+  echo "(please install an older version of GnuPG)" >&2
+  exit 1
+fi
+
 #
 # Download the list and verify.
 #
@@ -107,6 +113,11 @@ if [ $skip_download = yes ]; then
       exit 1
   fi
 else
+  if ! $WGET --version >/dev/null 2>/dev/null ; then
+      echo "command \"wget\" is not installed" >&2
+      exit 1
+  fi
+
   if ! $WGET -q -O swdb.lst "$urlbase/swdb.lst" ; then
       echo "download of swdb.lst failed." >&2
       exit 1