Require libgpg-error 1.11.
authorWerner Koch <wk@gnupg.org>
Mon, 25 Feb 2013 12:40:10 +0000 (13:40 +0100)
committerWerner Koch <wk@gnupg.org>
Tue, 5 Mar 2013 10:00:46 +0000 (11:00 +0100)
* configure.ac: Require libgpg-error 1.11.
* common/util.h (GPG_ERR_NO_KEYSERVER, GPG_ERR_INV_CURVE)
(GPG_ERR_UNKNOWN_CURVE): Remove fallback definitions.

common/util.h
configure.ac

index c8a008f..73ba84e 100644 (file)
 #include <gcrypt.h> /* We need this for the memory function protos. */
 #include <errno.h>  /* We need errno.  */
 #include <gpg-error.h> /* We need gpg_error_t. */
-/* Add error codes available only in newer versions of libgpg-error.  */
-#ifndef GPG_ERR_NO_KEYSERVER
-#define GPG_ERR_NO_KEYSERVER 186
-#endif
-#ifndef GPG_ERR_INV_CURVE
-#define GPG_ERR_INV_CURVE 187
-#endif
-#ifndef GPG_ERR_UNKNOWN_CURVE
-#define GPG_ERR_UNKNOWN_CURVE 188
-#endif
 
 
 /* Hash function used with libksba. */
index cf5ab3f..353546a 100644 (file)
@@ -43,7 +43,7 @@ m4_define([mym4_full_version],[mym4_version[]mym4_betastring])
 
 AC_INIT([gnupg],[mym4_full_version], [http://bugs.gnupg.org])
 
-NEED_GPG_ERROR_VERSION=1.10
+NEED_GPG_ERROR_VERSION=1.11
 
 NEED_LIBGCRYPT_API=1
 NEED_LIBGCRYPT_VERSION=1.5.0