Fix new test for v2 cards.
authorWerner Koch <wk@gnupg.org>
Mon, 18 Aug 2008 11:08:04 +0000 (11:08 +0000)
committerWerner Koch <wk@gnupg.org>
Mon, 18 Aug 2008 11:08:04 +0000 (11:08 +0000)
scd/ChangeLog
scd/app-openpgp.c

index 5e53fb9..1c453e8 100644 (file)
@@ -1,3 +1,7 @@
+2008-08-18  Werner Koch  <wk@g10code.com>
+
+       * app-openpgp.c (do_setattr): Fix test for v2 cards.
+
 2008-08-11  Werner Koch  <wk@g10code.com>
 
        * apdu.c (reset_pcsc_reader, open_pcsc_reader)
index cfc51ce..553d2fe 100644 (file)
@@ -1657,8 +1657,8 @@ do_setattr (app_t app, const char *name,
     ;
   if (!table[idx].name)
     return gpg_error (GPG_ERR_INV_NAME); 
-  if (!table[idx].need_v2)
-    return gpg_error (GPG_ERR_NOT_SUPPORTED); 
+  if (table[idx].need_v2)
+    return gpg_error (GPG_ERR_NOT_SUPPORTED); /* Not yet supported.  */
 
   switch (table[idx].need_chv)
     {