Release 2.1.21 gnupg-2.1.21
authorWerner Koch <wk@gnupg.org>
Mon, 15 May 2017 14:11:09 +0000 (16:11 +0200)
committerWerner Koch <wk@gnupg.org>
Mon, 15 May 2017 14:11:09 +0000 (16:11 +0200)
Signed-off-by: Werner Koch <wk@gnupg.org>
NEWS
README

diff --git a/NEWS b/NEWS
index 3c2b899..574f7da 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,25 @@
-Noteworthy changes in version 2.1.21 (unreleased)
+Noteworthy changes in version 2.1.21 (2017-05-15)
 -------------------------------------------------
 
+  * gpg,gpgsm: Fix corruption of old style keyring.gpg files.  This
+    bug was introduced with version 2.1.20.  Note that the default
+    pubring.kbx format was not affected.
+
+  * gpg,dirmngr: Removed the skeleton config file support.  The
+    system's standard methods for providing default configuration
+    files should be used instead.
+
+  * w32: The Windows installer now allows installion of GnuPG without
+    Administrator permissions.
+
+  * gpg: Fixed import filter property match bug.
+
+  * scd: Removed Linux support for Cardman 4040 PCMCIA reader.
+
+  * scd: Fixed some corner case bugs in resume/suspend handling.
+
+  * Many minor bug fixes and code cleanup.
+
 
 Noteworthy changes in version 2.1.20 (2017-04-03)
 -------------------------------------------------
diff --git a/README b/README
index 0ff9099..8be43d7 100644 (file)
--- a/README
+++ b/README
   can be freely used, modified and distributed under the terms of the
   GNU General Public License.
 
-  We are currently maintaining three branches of GnuPG:
-
-  - 2.1 (i.e. this release) is the latest stable version with a lot of
-    new features.
-
-  - 2.0 is an often used stable version.  This branch will reach
-    end-of-life on 2017-12-31.
-
-  - 1.4 is the old standalone version which is most suitable for older
-    or embedded platforms.
-
-  You may not install 2.1 and 2.0 at the same time.  However, it is
-  possible to install 1.4 along with any of the 2.x versions.
+  Note that the 2.0 series of GnuPG will reach end-of-life on
+  2017-12-31.  It is not possible to install a 2.1.x version along
+  with any 2.0.x version.  However, it is possible to install GnuPG
+  1.4 along with a 2.x version.
 
 
 * BUILD INSTRUCTIONS