Clarify that --force-v3-sigs disables (not enables) v4 options
authorDavid Shaw <dshaw@jabberwocky.com>
Tue, 28 Sep 2010 16:04:47 +0000 (16:04 +0000)
committerDavid Shaw <dshaw@jabberwocky.com>
Tue, 28 Sep 2010 16:04:47 +0000 (16:04 +0000)
doc/ChangeLog
doc/gpg.texi

index a61f54f..e27d9a9 100644 (file)
@@ -1,3 +1,9 @@
+2010-09-28  David Shaw  <dshaw@jabberwocky.com>
+
+       * gpg.texi (OpenPGP Options): Clarify that --force-v3-sigs
+       disables (not enables) v4 options.  --force-v3-sigs defaults to
+       no.
+
 2010-08-18  Werner Koch  <wk@g10code.com>
 
        * tools.texi (watchgnupg): Add examples section.
 
        * Makefile.am, gpgsm.texi: New.
        
- Copyright 2002, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
+ Copyright 2002, 2004, 2005, 2006, 2007, 2008, 2010 Free Software Foundation, Inc.
 
  This file is free software; as a special exception the author gives
  unlimited permission to copy and/or distribute it, with or without
index 3b22fa7..d35818e 100644 (file)
@@ -1,5 +1,5 @@
 @c Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007,
-@c               2008, 2009 Free Software Foundation, Inc.
+@c               2008, 2009, 2010 Free Software Foundation, Inc.
 @c This is part of the GnuPG manual.
 @c For copying conditions, see the file gnupg.texi.
 
@@ -1964,10 +1964,11 @@ the type of the signature.
 OpenPGP states that an implementation should generate v4 signatures
 but PGP versions 5 through 7 only recognize v4 signatures on key
 material. This option forces v3 signatures for signatures on data.
-Note that this option implies @option{--ask-sig-expire},
+Note that this option implies @option{--no-ask-sig-expire}, and unsets
 @option{--sig-policy-url}, @option{--sig-notation}, and
 @option{--sig-keyserver-url}, as these features cannot be used with v3
 signatures.  @option{--no-force-v3-sigs} disables this option.
+Defaults to no.
 
 @item --force-v4-certs
 @itemx --no-force-v4-certs
@@ -2541,10 +2542,7 @@ secret key.
 When making a data signature, prompt for an expiration time. If this
 option is not specified, the expiration time set via
 @option{--default-sig-expire} is used. @option{--no-ask-sig-expire}
-disables this option. Note that by default, @option{--force-v3-sigs} is
-set which also disables this option. If you want signature expiration,
-you must set @option{--no-force-v3-sigs} as well as turning
-@option{--ask-sig-expire} on.
+disables this option.
 
 @item --default-sig-expire
 The default expiration time to use for signature expiration. Valid