gpg: Remove superfluous check for Libgcrypt >= 1.4.0.
authorWerner Koch <wk@gnupg.org>
Fri, 31 Oct 2014 13:47:02 +0000 (14:47 +0100)
committerWerner Koch <wk@gnupg.org>
Fri, 31 Oct 2014 13:47:02 +0000 (14:47 +0100)
* g10/gpg.c (main): Remove check.
--

We require 1.6.0 anyway.

g10/gpg.c

index 1df44fe..470d152 100644 (file)
--- a/g10/gpg.c
+++ b/g10/gpg.c
@@ -3202,15 +3202,6 @@ main (int argc, char **argv)
         log_set_prefix (NULL, 1|2|4);
       }
 
-    /* Older Libgcrypts fail with an assertion during DSA key
-       generation.  Better disable DSA2 entirely. */
-    if (opt.flags.dsa2 && !gcry_check_version ("1.4.0") )
-      {
-        log_info ("WARNING: "
-                  "DSA2 is only available with Libgcrypt 1.4 and later\n");
-        opt.flags.dsa2 = 0;
-      }
-
     if (opt.verbose > 2)
         log_info ("using character set '%s'\n", get_native_charset ());