gpgscm: Fix -Wimplicit-fallthrough warnings.