Bump version number for the next release.
authorWerner Koch <wk@gnupg.org>
Wed, 10 Jul 2013 13:18:00 +0000 (15:18 +0200)
committerWerner Koch <wk@gnupg.org>
Wed, 10 Jul 2013 13:29:17 +0000 (15:29 +0200)
--
Also cleaned up the README files.

NEWS
configure.ac
doc/README.de.txt
doc/README.en.txt

diff --git a/NEWS b/NEWS
index 2afcf99..ddac74b 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -3,7 +3,7 @@
 # The version number given below are for the standard installers as
 # distributed by www.gpg4win.org.
 
-Noteworthy changes in version 2.1.2 (unreleased)
+Noteworthy changes in version 2.2.0 (unreleased)
 ------------------------------------------------
 
 (en) GpgEx does now work on 64 bit Windows.
index c700dd0..a3ccdb8 100644 (file)
@@ -27,7 +27,7 @@ min_automake_version="1.9.3"
 # commit and push so that the git magic is able to work.
 #
 # After a release the make target "copy-news" is to be called as well!
-m4_define([my_version], [2.1.2])
+m4_define([my_version], [2.2.0])
 
 # Below is m4 magic to extract and compute the git revision number,
 # the decimalized short revision number, a beta version string and a
index 6bc4f5c..cb07ba2 100644 (file)
@@ -43,10 +43,6 @@ Gpg4win unterst
 
   * MS Outlook: 2003, 2007
 
-Wichtig: Das Explorer-Plugin 'GpgEX' bietet aktuell keine
-         Unterstützung für 64-bit Explorer!
-         (Details in Abschnitt 3, Punkt "Probleme unter Windows x64")
-
 
 2. Änderungen
 =============
@@ -63,7 +59,7 @@ Neu in Gpg4win Version !VERSION! (!BUILD_ISODATE!)
   * aktualisiert auf Kleopatra 2.1.1 (aus KDE 4.10.3)
   * Defekte in None-Latin-Umgebungen behoben
   * zahlreiche Stabilitätsverbesserungen
+
 - Qt:
   * aktualisiert von Qt 4.4.0 auf 4.8.4
   * zahlreiche UI-Verbesserungen in Kleopatra
@@ -72,7 +68,7 @@ Neu in Gpg4win Version !VERSION! (!BUILD_ISODATE!)
 - GnuPG-Backend:
   * aktualisiert auf gnupg 2.0.20
   * diverse Bibliotheken aktualisiert (u.a. gpgme, dirmngr,
-    libassuan, libgcrypt, libgpg-error, libksba, pinentry, 
+    libassuan, libgcrypt, libgpg-error, libksba, pinentry,
     libpng u.v.m - siehe Datei 'packages.current' im Gpg4win-Repository)
   * GPGPME bug behoben, der zu Hänger von Kleopatra führte
 
@@ -138,10 +134,6 @@ Neu in Gpg4win Version !VERSION! (!BUILD_ISODATE!)
     (Hinweis: Beim verwenden von SMTP sollte das Senden
      mit GpgOL funktionieren.)
 
-  * Outlook2007 stürzt beim Öffnen von Anhängen einer
-    verschlüsselten Nachricht ab
-    [siehe https://bugs.g10code.com/gnupg/issue1110]
-
   * Verschlüsselte E-Mails unverschlüsselt auf E-Mail-Server:
     Es kann vorkommen, dass Teile von verschlüsselten E-Mails
     in entschlüsselter/unverschlüsselter Form auf dem E-Mail-Server
@@ -153,30 +145,6 @@ Neu in Gpg4win Version !VERSION! (!BUILD_ISODATE!)
     aber es kann trotzdem noch passieren.
     Eine Lösung hierfür ist in Arbeit.
 
-- Verwendung von GpgEX:
-
-   * Es kann teilweise vorkommen, dass beim Versuch Dateien mit GpgEX
-     aus dem Explorer zu signieren/verschlüsseln bzw. zu entschlüsseln/prüfen,
-     Kleopatra und das aktive Explorerfenster nicht mehr reagiert.
-     Sie sollten Kleopatra dann über den Task-Manager beendet und die
-     Datei-Krypto-Opteration nicht über GpgEX sondern direkt über
-     Kleopatra (per Datei-Menü) ausführen.
-
-   * Probleme unter Windows x64:
-     GpgEX ist eine (32bit) Erweiterung für den (32bit) Windows
-     Explorer und läuft _nicht_ in einem 64bit Explorer
-     (= voreingestellter Explorer in einem Windows 64bit System).
-
-     Abhilfe: Starten Sie den 32bit Explorer, um GpgEX nutzen zu können.
-     Klicken Sie auf "Start" -> "Ausführen" und geben Sie folgenden
-     Befehl ein:
-        C:\windows\syswow64\explorer.exe /separate
-     Beachten Sie, dass Sie ggf. den Pfad zu Ihrer x64-basierten
-     Version von Windows anpassen müssen.
-     Dieser 'separate'-Aufruf ist aktuell in Windows7/64bit defekt.
-     Alternativ können Sie die Datei-Krypto-Operationen von GpgEX
-     auch direkt über das Datei-Menü von Kleopatra erreichen.
-
 
 4. Installation
 ===============
index f407ecc..b0ab893 100644 (file)
@@ -40,9 +40,6 @@ Gpg4win supports these platforms:
 
   * MS Outlook: 2003, 2007
 
-Note: Currently, there is no 64-bit support for GpgEX
-      (see section 3, "Using GpgEX with Windows x64", for details)
-
 
 2. Changes
 ==========
@@ -59,16 +56,16 @@ New in Gpg4win Version !VERSION! (!BUILD_ISODATE!)
   * Updated to Kleopatra 2.1.1 (from KDE 4.10.3).
   * Fixed bugs in none latin environments.
   * Several minor and medium improvements of stability.
+
 - Qt:
-  * Updated to 4.8.4 (from Qt 4.4.0) with a lot of 
+  * Updated to 4.8.4 (from Qt 4.4.0) with a lot of
     improvements in Kleopatra UI.
   * Improved support for Windows7 and Windows8.
 
 - GnuPG-Backend:
   * Updated to gnupg 2.0.20.
   * Updated most included packages to recent versions (e.g. gpgme,
-    dirmngr, libassuan, libgcrypt, libgpg-error, libksba, pinentry, 
+    dirmngr, libassuan, libgcrypt, libgpg-error, libksba, pinentry,
     libpng and much more - see 'packages.current' file in Gpg4win git
     repository).
   * Fixed a long standing bug in GPGME which led to spurious Kleopatra
@@ -131,9 +128,6 @@ New in Gpg4win Version !VERSION! (!BUILD_ISODATE!)
     [see https://bugs.g10code.com/gnupg/issue1102]
     (Please note: Using SMTP with GpgOL and Exchange seems to be work.)
 
-  * Outlook2007 crashes after opening attachments of an encrypted message
-    [see https://bugs.g10code.com/gnupg/issue1110]
-
   * Encrypted E-Mails occuring un-encrypted on the email server: It
     can happen that parts of encrypted emails are copied to your email
     server (IMAP or MAPI) in un-encrypted/decrypted form when creating
@@ -143,28 +137,6 @@ New in Gpg4win Version !VERSION! (!BUILD_ISODATE!)
     probability of this to happen, but not eliminate the issue.
     A solution is being worked on.
 
-- Using GpgEX with 64 bit versions Windows:
-
-   * In some cases sign/encrypt or decrypt/verify via GpgEX doesn't work
-     correctly (Kleopatra freezed). Then you should kill Kleopatra via
-     task manager and run the file crypto operation directly in Kleopatra
-     (see file menu).
-
-   * Problems with Windows x64:
-     GpgEX is a (32bit) plugin for the (32bit) Windows
-     Explorer and it does _not_ run in a 64bit Explorer
-     (= default for a Windows 64bit system).
-
-     Workaround: Run the 32bit Explorer to use GpgEX.
-     Click "Start" -> "Run", type the following in the box, and then
-     click OK:
-         C:\windows\syswow64\explorer.exe /separate
-     Note: Adjust the path to your x64-based version of Windows if
-     necessary.
-     This 'separate' command seems to be currently broken in Windows7/64bit.
-     Alternatively you can use the file crypto operations of GpgEX
-     directly via the file menu of Kleopatra.
-
 
 4. Installation
 ===============