Schizophrenic file types
[gpgme.git] / lang / python / README
1 #+TITLE gpg - GPGME bindings for Python
2
3
4 The "gpg" module is a python interface to the GPGME library:
5 https://www.gnupg.org/related_software/gpgme/
6
7 "gpg" offers two interfaces, one is a high-level, curated, and
8 idiomatic interface that is implemented as a shim on top of the
9 low-level interface automatically created using SWIG.
10
11 This way we make simple things easy, while still providing the entire
12 functionality of the underlying library.
13
14 * Mailing List
15
16 For general discussion and help see the gnupg-users mailing list:
17 https://lists.gnupg.org/mailman/listinfo/gnupg-users
18
19 For development see the gnupg-devel mailing list:
20 https://lists.gnupg.org/mailman/listinfo/gnupg-devel
21
22 * Bugs
23
24 Please report bugs using our bug tracker using the category 'gpgme',
25 and topic 'python':
26 https://bugs.gnupg.org/gnupg/
27
28 * Authors
29
30 PyME was created by John Goerzen, and maintained, developed, and
31 cherished by Igor Belyi, Martin Albrecht, Ben McGinnes, and everyone
32 who contributed to it in any way.
33
34 In 2016 we merged a port of PyME to into the GPGME repository, and
35 development will continue there.  Please see the VCS history for the
36 list of contributors, and if you do find bugs, or want to contribute,
37 please get in touch and help maintain the python gpg bindings.
38
39 Please see the section 'History' further down this document for
40 references to previous versions.
41
42 * History
43
44  - The python bindings were renamed from PyME to "gpg" in 2016.
45
46  - The bindings have been merged into the GPGME repository in 2016.
47
48  - The latest version of PyME for Python 3.2 and above (as of
49    May, 2015) is v0.9.1.
50    https://git.gnupg.org/gpgme.git/lang/py3-pyme
51
52  - The latest version of PyME for Python 2.6 and 2.7 (as of this
53    writing) is v0.9.0.  https://bitbucket.org/malb/pyme
54
55  - A previous version of PyME v0.8.0 can be found on sourceforge:
56    http://pyme.sourceforge.net/
57
58  - A previous version of PyME v0.5.1 which works with GPGME v0.3.15
59    can be found on John Goerzen's PyME page:
60    http://quux.org/devel/pyme/
61    http://www.complete.org/JohnGoerzen