Short History
[gpgme.git] / lang / python / docs / Short_History.org
1 #+TITLE: A Short History of the GPGME bindings for Python
2
3 * Overview
4   :PROPERTIES:
5   :CUSTOM_ID: overview
6   :END:
7
8 The GPGME Python bindings passed through many hands and numerous
9 phases before, after a fifteen year journey, coming full circle to
10 return to the source.  This is a short explanation of that journey.
11
12 ** In the beginning
13    :PROPERTIES:
14    :CUSTOM_ID: in-the-begining
15    :END:
16
17    In 2002 John Goerzen released PyME; Python bindings for the GPGME
18    module which utilised the current release of Python of the time
19    (Python 2.2 or 2.3) and SWIG.  Shortly after creating it and
20    ensuring it worked he stopped supporting it, though he left his
21    work available on his Gopher site.
22
23 ** Keeping the flame alive
24    :PROPERTIES:
25    :CUSTOM_ID: keeping-the-flame-alive
26    :END:
27
28    A couple of years later the project was picked up by Igor Belyi and
29    actively developed and maintained by him from 2004 to 2008.  Igor's
30    whereabouts at the time of this document's creation are unknown,
31    but the current authors do hope he is well.  We're assuming (or
32    hoping) that life did what life does and made continuing untenable.
33
34 ** Passing the torch
35    :PROPERTIES:
36    :CUSTOM_ID: passing-the-torch
37    :END:
38
39    In 2014 Martin Albrecht wanted to patch a bug in the PyME code and
40    discovered the absence of Igor.  Following a discussion on the PyME
41    mailing list he became the new maintainer for PyME, releasing
42    version 0.9.0 in May of that year.  He remains the maintainer of
43    the original PyME release in Python 2.6 and 2.7 (available via
44    PyPI).
45
46 ** Coming full circle
47    :PROPERTIES:
48    :CUSTOM_ID: ouroboros 
49    :END:
50
51    In 2015 Ben McGinnes approached Martin about a Python 3 version,
52    while investigating how complex a task this would be the task ended
53    up being completed.  A subsequent discussion with Werner Koch led
54    to the decision to fold the Python 3 port back into the original
55    GPGME release in the languages subdirectory for non-C bindings
56    under the module name of =pyme3=.
57
58    In 2016 this PyME module was integrated back into the GPGME project
59    by Justus Winter.  During the course of this work Justus adjusted
60    the port to restore limited support for Python 2, but not as many
61    minor point releases as the original PyME package supports.  During
62    the course of this integration the package was renamed to more
63    accurately reflect its status as a component of GPGME.  The =pyme3=
64    module was renamed to =gpg= and adopted by the upstream GnuPG team.
65
66    In 2017 Justus departed G10code and the GnuPG team.  Following this
67    Ben returned to maintain of gpgme Python bindings and continue
68    building them from that point.
69
70 * Relics of the past
71   :PROPERTIES:
72   :CUSTOM_ID: relics-past
73   :END:
74
75 There are a few things, in addition to code specific factors, such as
76 SWIG itself, which are worth noting here.
77
78 ** The Annoyances of Git
79    :PROPERTIES:
80    :CUSTOM_ID: the-annoyances-of-git
81    :END:
82
83    As anyone who has ever worked with git knows, submodules are
84    horrible way to deal with pretty much anything.  In the interests
85    of avoiding migraines, that was skipped with addition of the PyME
86    code to GPGME.
87
88    Instead the files were added to a subdirectory of the =lang/=
89    directory, along with a copy of the entire git log up to that point
90    as a separate file within the =lang/python/docs/= directory.[fn:1]
91    As the log for PyME is nearly 100KB and the log for GPGME is
92    approximately 1MB, this would cause considerable bloat, as well as
93    some confusion, should the two be merged.
94
95    Hence the unfortunate, but necessary, step to simply move the
96    files.  A regular repository version has been maintained should it
97    be possible to implement this better in the future.
98
99 ** The Perils of PyPI
100    :PROPERTIES:
101    :CUSTOM_ID: the-perils-of-pypi
102    :END:
103
104    The early port of the Python 2 =pyme= module as =pyme3= was never
105    added to PyPI while the focus remained on development and testing
106    during 2015 and early 2016.  Later in 2016, however, when Justus
107    completed his major integration work and subsequently renamed the
108    module from =pyme3= to =gpg=, some prior releases were also
109    provided through PyPI.
110
111    Since these bindings require a matching release of the GPGME
112    libraries in order to function, it was determined that there was
113    little benefit in also providing a copy through PyPI since anyone
114    obtaining the GPGME source code would obtain the Python bindings
115    source code at the same time.  Whereas there was the potential to
116    sew confusion amongst Python users installing the module from PyPI,
117    only to discover that without the relevant C files, header files or
118    SWIG compiled binaries, the Python module did them little good.
119
120    There are only two files on PyPI which might turn up in a search
121    for this module or a sample of its content:
122
123    1. gpg (1.8.0) - Python bindings for GPGME GnuPG cryptography library
124    2. pyme (0.9.0) - Python support for GPGME GnuPG cryptography library
125
126 *** GPG 1.8.0 - Python bindings for GPGME GnuPG cryptography library
127     :PROPERTIES:
128     :CUSTOM_ID: pypi-gpgme-180
129     :END:
130
131     This is the most recent version to reach PyPI and is the version
132     of the official Pyhon bindings which shipped with GPGME 1.8.0.  If
133     you have GPGME 1.8.0 installed and /only/ 1.8.0 installed, then it
134     is probably safe to use this copy from PyPI.
135
136     As there have been a lot of changes since the release of GPGME
137     1.8.0, the GnuPG Project recommends not using this version of the
138     module and instead installing the current version of GPGME along
139     with the Python bindings included with that package.
140
141 *** PyME 0.9.0 - Python support for GPGME GnuPG cryptography library
142     :PROPERTIES:
143     :CUSTOM_ID: pypi-gpgme-90
144     :END:
145
146     This is the last release of the PyME bindings maintained by Martin
147     Albrecht and is only compatible with Python 2, it will not work
148     with Python 3.  This is the version of the software from which the
149     port from Python 2 to Python 3 code was made in 2015.
150
151     Users of the more recent Python bindings will recognise numerous
152     points of similarity, but also significant differences.  It is
153     likely that the more recent official bindings will feel "more
154     pythonic."
155
156     For those using Python 2, there is essentially no harm in using
157     this module, but it may lack a number of more recent features
158     added to GPGME.
159
160 * Footnotes
161
162 [fn:1] The entire PyME git log and other preceding VCS logs are
163 located in the =gpgme/lanf/python/docs/old-commits.log= file.