Add GPGME_PROTOCOL_SPAWN and gpgme_op_spawn.
[gpgme.git] / README
diff --git a/README b/README
index be07a0f..3b39215 100644 (file)
--- a/README
+++ b/README
@@ -26,10 +26,11 @@ GPGME uses GnuPG and GpgSM as its backends to support OpenPGP and the
 Cryptographic Message Syntax (CMS).
 
 GPGME runs best on GNU/Linux or *BSD systems.  Other Unices may
-require small portability fixes, send us your patches.
+require small portability fixes, please send us your patches.
 
-See the file COPYING.LESSER and each file for copyright and warranty
-information.
+See the files COPYING, COPYING.LESSER, and each file for copyright and
+warranty information.  The file AUTHORS has a list of authors and
+useful web and mail addresses.
 
 
 Installation
@@ -40,7 +41,7 @@ See the file INSTALL for generic installation instructions.
 Check that you have unmodified sources.  See below on how to do this.
 Don't skip it - this is an important step!
 
-To build GPGME, you need to install libgpg-error (>= 1.8) and
+To build GPGME, you need to install libgpg-error (>= 1.11) and
 Libassuan (>= 2.0.2).
 
 For support of the OpenPGP protocol (default), you should use the
@@ -49,12 +50,9 @@ ftp://ftp.gnupg.org/gcrypt/gnupg/
 For support of the CMS (Cryptographic Message Syntax) protocol, you
 need a GnuPG version >= 2.0.
 
-If configure can't find the `gpg' binary in your path, you can specify
-the location with the --with-gpg=/path/to/gpg argument to configure.
-
-If configure can't find the `gpgsm' binary in your path, you can
-specify the location with the --with-gpgsm=/path/to/gpgsm argument to
-configure.
+On some platforms GPGME based applications might hang at certain
+operations when using GPGME_PROTOCOL_CMS.  A workaround for this
+problem is to build with the configure option --disable-fd-passing.
 
 For building the GIT version of GPGME please see the file README.GIT
 for more information.