qt: Undeprecate API that I find useful
authorAndre Heinecke <aheinecke@intevation.de>
Wed, 10 May 2017 08:22:23 +0000 (10:22 +0200)
committerAndre Heinecke <aheinecke@intevation.de>
Wed, 10 May 2017 08:22:23 +0000 (10:22 +0200)
commitcc2ef3d07c0d261bb9e8e8c0f2706e1a08e4ec53
treece5c04a5e43642a2726330de024627849580d4ca
parentb56f398eff4e3e70dea714c3174a5512dd9bcf33
qt: Undeprecate API that I find useful

* lang/qt/src/decryptjob.h,
lang/qt/src/decryptverifyjob.h,
lang/qt/src/signencryptjob.h,
lang/qt/src/verifydetachedjob.h,
lang/qt/src/verifyopaquejob.h: Undeprecate ByteArray based API.

--
While an IODevice may be more performant the ByteArray API is
a very easy way to get started with QGpgME as it allows you
basically to encrypt / decrypt any QString.

This also fixes a ton of deprecation warnings in KDE where this
API is used all over the place.
lang/qt/src/decryptjob.h
lang/qt/src/decryptverifyjob.h
lang/qt/src/signencryptjob.h
lang/qt/src/verifydetachedjob.h
lang/qt/src/verifyopaquejob.h