python: windows c and cython
authorBen McGinnes <ben@adversary.org>
Tue, 4 Dec 2018 23:51:59 +0000 (10:51 +1100)
committerBen McGinnes <ben@adversary.org>
Tue, 4 Dec 2018 23:51:59 +0000 (10:51 +1100)
* added warning that he Windows C runtime issues will also affect use
  with Cython and that relying on binary installers would remove that
  possible use case.

lang/python/doc/rst/gpgme-python-howto.rst
lang/python/doc/src/gpgme-python-howto
lang/python/doc/texinfo/gpgme-python-howto.texi

index 7843a65..3750d9a 100644 (file)
@@ -547,6 +547,14 @@ versions for CPython 2.7 and 3.4, with 64-bit versions for both x86-64
 (i.e. Intel and AMD) and ARM architectures for CPython 3.5, 3.6, 3.7 and
 later releases. That\'s the bare **minimum**, it\'d probably be higher.
 
+Additionally, with only a binary installation used in conjunction with
+the CPython installer from ``python.org`` the advanced options available
+which utilise `Cython <#cython>`__ will not be able to be used at all.
+Cython depends on being able to compile the C code it generates and that
+too would need to utilise a matching runtime to both the installed
+version of CPython and these bindings in order to work with the
+bindings.
+
 Considering all of that, what do we recommend?
 
 #. Use a recent version of CPython; at least 3.5, but ideally 3.6 or
index 5436bfb..c6b0002 100644 (file)
@@ -569,6 +569,13 @@ x86-64 (i.e. Intel and AMD) and ARM architectures for CPython 3.5,
 3.6, 3.7 and later releases.  That's the bare *minimum*, it'd probably
 be higher.
 
+Additionally, with only a binary installation used in conjunction with
+the CPython installer from =python.org= the advanced options available
+which utilise [[#cython][Cython]] will not be able to be used at all.  Cython
+depends on being able to compile the C code it generates and that too
+would need to utilise a matching runtime to both the installed version
+of CPython and these bindings in order to work with the bindings.
+
 Considering all of that, what do we recommend?
 
  1. Use a recent version of CPython; at least 3.5, but ideally 3.6 or
index a68026d..bfc42f3 100644 (file)
@@ -747,6 +747,13 @@ x86-64 (i.e. Intel and AMD) and ARM architectures for CPython 3.5,
 3.6, 3.7 and later releases.  That's the bare @strong{minimum}, it'd probably
 be higher.
 
+Additionally, with only a binary installation used in conjunction with
+the CPython installer from @samp{python.org} the advanced options available
+which utilise @ref{C plus Python plus SWIG plus Cython, , Cython} will not be able to be used at all.  Cython
+depends on being able to compile the C code it generates and that too
+would need to utilise a matching runtime to both the installed version
+of CPython and these bindings in order to work with the bindings.
+
 Considering all of that, what do we recommend?
 
 @enumerate