m4 update: python 3.7
authorBen McGinnes <ben@adversary.org>
Fri, 29 Jun 2018 04:52:37 +0000 (14:52 +1000)
committerBen McGinnes <ben@adversary.org>
Fri, 29 Jun 2018 04:52:37 +0000 (14:52 +1000)
* Fixed an error in arcane m4 syntax.

m4/python.m4

index db7b482..56220ba 100644 (file)
 AC_DEFUN([AM_PATH_PYTHON],
  [
   dnl Find a Python interpreter.  Python versions prior to 2.0 are not
-  dnl supported. (2.0 was released on October 16, 2000).
+  dnl supported. (2.0 was released on October 16, 2000).  Python 3.0
+  dnl through to Python 3.3 are also not supported.
   m4_define_default([_AM_PYTHON_INTERPRETER_LIST],
 [python2 python2.7 dnl
  python dnl
- dnl old listing was pointless since biundings only work from Python 3.4:
- dnl python3 python3.0 python3.1 python3.2 python3.3
- dnl move 3.7 to the front once 3.7.1 or 3.7.2 is released:
- dnl python3 python3.7 python3.6 python3.5 python3.4 python3.8])
- dnl until then:
- python3 python3.6 python3.5 python3.4 python3.7 python3.8])
+ python3 python3.6 python3.5 python3.4 python3.7  dnl
+ python3.8])
 
   AC_ARG_VAR([PYTHON], [the Python interpreter])