Release 1.11.0 gpgme-1.11.0
authorWerner Koch <wk@gnupg.org>
Wed, 18 Apr 2018 17:41:45 +0000 (19:41 +0200)
committerWerner Koch <wk@gnupg.org>
Wed, 18 Apr 2018 18:11:52 +0000 (20:11 +0200)
* configure.ac: Bump LT version to C31/A20/R0.  For cpp to C12/A6/R0.
For qt to: C10/A3/R1.

Signed-off-by: Werner Koch <wk@gnupg.org>
NEWS
configure.ac

diff --git a/NEWS b/NEWS
index b4488cc..b7c091c 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,4 +1,4 @@
-Noteworthy changes in version 1.10.1 (unreleased)
+Noteworthy changes in version 1.11.0 (2018-04-18)
 -------------------------------------------------
 
  * New encryption API to support direct key specification including
@@ -6,7 +6,7 @@ Noteworthy changes in version 1.10.1 (unreleased)
    allows to enforce the use of a subkey.
 
  * New encryption flag for the new API to enforce the use of plain
-   mail address (addr-spec).
+   mail addresses (addr-spec).
 
  * The import API can now tell whether v3 keys are skipped.  These old
    and basically broken keys are not anymore supported by GnuPG 2.1.
@@ -57,6 +57,8 @@ Noteworthy changes in version 1.10.1 (unreleased)
  cpp: Data::toString              NEW.
  cpp: ImportResult::numV3KeysSkipped  NEW.
 
+ [c=C31/A20/R0 cpp=C12/A6/R0 qt=C10/A3/R1]
+
 
 Noteworthy changes in version 1.10.0 (2017-12-12)
 -------------------------------------------------
index e42f178..a04b059 100644 (file)
@@ -28,8 +28,8 @@ min_automake_version="1.14"
 # commit and push so that the git magic is able to work.  See below
 # for the LT versions.
 m4_define(mym4_version_major, [1])
-m4_define(mym4_version_minor, [10])
-m4_define(mym4_version_micro, [1])
+m4_define(mym4_version_minor, [11])
+m4_define(mym4_version_micro, [0])
 
 # Below is m4 magic to extract and compute the revision number, the
 # decimalized short revision number, a beta version string, and a flag
@@ -55,20 +55,20 @@ AC_INIT([gpgme],[mym4_full_version],[http://bugs.gnupg.org])
 #   (Interfaces added:                 AGE++)
 #   (Interfaces removed/changed:       AGE=0)
 #
-LIBGPGME_LT_CURRENT=30
-LIBGPGME_LT_AGE=19
+LIBGPGME_LT_CURRENT=31
+LIBGPGME_LT_AGE=20
 LIBGPGME_LT_REVISION=0
 
 # If there is an ABI break in gpgmepp or qgpgme also bump the
 # version in IMPORTED_LOCATION in the GpgmeppConfig-w32.cmake.in.in
 
-LIBGPGMEPP_LT_CURRENT=11
-LIBGPGMEPP_LT_AGE=5
+LIBGPGMEPP_LT_CURRENT=12
+LIBGPGMEPP_LT_AGE=6
 LIBGPGMEPP_LT_REVISION=0
 
 LIBQGPGME_LT_CURRENT=10
 LIBQGPGME_LT_AGE=3
-LIBQGPGME_LT_REVISION=0
+LIBQGPGME_LT_REVISION=1
 
 # If the API is changed in an incompatible way: increment the next counter.
 GPGME_CONFIG_API_VERSION=1