2007-09-07 Marcus Brinkmann <marcus@g10code.de>
authorMarcus Brinkmann <mb@g10code.com>
Fri, 7 Sep 2007 20:54:12 +0000 (20:54 +0000)
committerMarcus Brinkmann <mb@g10code.com>
Fri, 7 Sep 2007 20:54:12 +0000 (20:54 +0000)
* Makefile.am (libgpgme_qt_la_SOURCES): Move
moc_kdpipeiodevice.cpp to EXTRA_DIST, as this is only included by
another file (it's more like a header file than a cpp file, but
automake doesn't know that).

gpgme/ChangeLog
gpgme/Makefile.am
gpgme/gpgme.h

index 75bd6a2..4605d67 100644 (file)
@@ -1,5 +1,10 @@
 2007-09-07  Marcus Brinkmann  <marcus@g10code.de>
 
+       * Makefile.am (libgpgme_qt_la_SOURCES): Move
+       moc_kdpipeiodevice.cpp to EXTRA_DIST, as this is only included by
+       another file (it's more like a header file than a cpp file, but
+       automake doesn't know that).
+
        * w32-qt-io.cpp (_gpgme_io_spawn): Fix several cast errors and typos.
        * w32-io.c (_gpgme_io_write): Use TRACE_SYSRES instead of TRACE_SYS.
        (libgpgme_qt_la_LIBADD): Add QT4_CORE_LIBS, not QT4_CORE_LIB.
index 8668b36..18b44de 100644 (file)
@@ -19,8 +19,9 @@
 
 ## Process this file with automake to produce Makefile.in
 
+# Note: moc_kdpipeiodevice should actually be a dependcy below.
 EXTRA_DIST = gpgme-config.in gpgme.m4 mkstatus libgpgme.vers \
-            versioninfo.rc.in gpgme.def
+            versioninfo.rc.in gpgme.def moc_kdpipeiodevice.cpp
 BUILT_SOURCES = status-table.h
 MOSTLYCLEANFILES = status-table.h
 bin_SCRIPTS = gpgme-config
@@ -115,8 +116,8 @@ endif
 
 if BUILD_W32_QT
 libgpgme_qt_la_SOURCES = $(main_sources) ath.h ath.c w32-qt-io.cpp \
-       kdpipeiodevice.h kdpipeiodevice.cpp moc_kdpipeiodevice.cpp \
-       kdpipeiodevice.moc
+       kdpipeiodevice.h kdpipeiodevice.cpp kdpipeiodevice.moc
+# FIXME: Add extra depedency: moc_kdpipeiodevice.cpp
 
 # These are built sources (normally).
 # moc_kdpipeiodevice.cpp: kdpipeiodevice.h
index d15b921..5bdd103 100644 (file)
@@ -73,7 +73,7 @@ extern "C" {
    AM_PATH_GPGME macro) check that this header matches the installed
    library.  Warning: Do not edit the next line.  configure will do
    that for you!  */
-#define GPGME_VERSION "1.1.5-cvs1250"
+#define GPGME_VERSION "1.1.5-cvs1251"
 
 
 \f