Release 1.8.0 gpgme-1.8.0
authorWerner Koch <wk@gnupg.org>
Wed, 16 Nov 2016 12:29:02 +0000 (13:29 +0100)
committerWerner Koch <wk@gnupg.org>
Wed, 16 Nov 2016 12:29:02 +0000 (13:29 +0100)
* configure.ac: Set version to 1.8.0.  Set LT version C28/A17/RO.
Set CPP LT version to C9/A3/R0.  Set Qt LT version to C8/A1/R0.
--

Signed-off-by: Werner Koch <wk@gnupg.org>
NEWS
README
configure.ac

diff --git a/NEWS b/NEWS
index c194d8f..bbafdeb 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,10 +1,23 @@
-Noteworthy changes in version 1.7.2 (unreleased)
+Noteworthy changes in version 1.8.0 (2016-11-16)
 ------------------------------------------------
 
  * The module of the Python bindings has been renamed to 'gpg'.
 
+ * New interface to query current software versions.
+
+ * New feature to use gpg's --{show,override}session-key options.
+
+ * New interface to set the sender of a mail.
+
  * qt: Added Distinguished Name parser from libkleo
 
+ * The --homedir option is now used with recent gpgconf versions.
+
+ * On 64 bit Windows systems gpgconf is now properly located.
+
+ * The internal locking functions have been replaced by libgpg-error
+   locking functions.
+
  * Interface changes relative to the 1.7.1 release:
  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  gpgme_set_sender                NEW.
@@ -13,6 +26,7 @@ Noteworthy changes in version 1.7.2 (unreleased)
  gpgme_op_query_swdb_result      NEW.
  gpgme_query_swdb_result_t       NEW.
  gpgme_get_ctx_flag              NEW.
+ gpgme_decrypt_result_t          EXTENDED: New field session_key.
  qt: DN                          NEW.
  qt: DN::Attribute               NEW.
  qt: Job::context(Job*)          NEW.
@@ -22,6 +36,8 @@ Noteworthy changes in version 1.7.2 (unreleased)
  cpp: Context::setSender(const char*)           NEW.
  cpp: Context::getSender()                      NEW.
 
+ [c=C28/A17/R0 cpp=C9/A3/R0 qt=C8/A1/R0]
+
 
 Noteworthy changes in version 1.7.1 (2016-10-18)
 ------------------------------------------------
diff --git a/README b/README
index 90f2e39..b7483b2 100644 (file)
--- a/README
+++ b/README
@@ -64,7 +64,7 @@ following ways:
 a) If you have a trusted Version of GnuPG installed, you can simply check
    the supplied signature:
 
-       $ gpg --verify gpgme-x.y.z.tar.gz.sig
+       $ gpg --verify gpgme-x.y.z.tar.gz.sig gpgme-x.y.z.tar.gz
 
    This checks that the detached signature gpgme-x.y.z.tar.gz.sig is
    indeed a a signature of gpgme-x.y.z.tar.gz.  The key used to create
index 4d2f8d6..0a67b48 100644 (file)
@@ -28,8 +28,8 @@ min_automake_version="1.14"
 # commit and push so that the git magic is able to work.  See below
 # for the LT versions.
 m4_define(mym4_version_major, [1])
-m4_define(mym4_version_minor, [7])
-m4_define(mym4_version_micro, [2])
+m4_define(mym4_version_minor, [8])
+m4_define(mym4_version_micro, [0])
 
 # Below is m4 magic to extract and compute the revision number, the
 # decimalized short revision number, a beta version string, and a flag
@@ -55,19 +55,19 @@ AC_INIT([gpgme],[mym4_full_version],[http://bugs.gnupg.org])
 #   (Interfaces added:                 AGE++)
 #   (Interfaces removed/changed:       AGE=0)
 #
-LIBGPGME_LT_CURRENT=27
-LIBGPGME_LT_AGE=16
+LIBGPGME_LT_CURRENT=28
+LIBGPGME_LT_AGE=17
 LIBGPGME_LT_REVISION=0
 
 # If there is an ABI break in gpgmepp or qgpgme also bump the
 # version in IMPORTED_LOCATION in the GpgmeppConfig-w32.cmake.in.in
 
-LIBGPGMEPP_LT_CURRENT=8
-LIBGPGMEPP_LT_AGE=2
+LIBGPGMEPP_LT_CURRENT=9
+LIBGPGMEPP_LT_AGE=3
 LIBGPGMEPP_LT_REVISION=0
 
-LIBQGPGME_LT_CURRENT=7
-LIBQGPGME_LT_AGE=0
+LIBQGPGME_LT_CURRENT=8
+LIBQGPGME_LT_AGE=1
 LIBQGPGME_LT_REVISION=0
 
 # If the API is changed in an incompatible way: increment the next counter.