Release 1.7.2 libgcrypt-1.7.2
authorWerner Koch <wk@gnupg.org>
Thu, 14 Jul 2016 09:23:34 +0000 (11:23 +0200)
committerWerner Koch <wk@gnupg.org>
Thu, 14 Jul 2016 09:28:52 +0000 (11:28 +0200)
* configure.ac: Set LT version to C21/A1/R2.
* Makefile.am (distcheck-hook): New.

Signed-off-by: Werner Koch <wk@gnupg.org>
Makefile.am
NEWS
configure.ac

index 2e7abc4..f946df2 100644 (file)
@@ -59,6 +59,21 @@ dist-hook: gen-ChangeLog
        @set -e; \
        echo "$(VERSION)" > $(distdir)/VERSION
 
+distcheck-hook:
+       set -e; ( \
+       pref="#+macro: $$(echo $(PACKAGE_NAME)|tr '-' '_')_" ;\
+       reldate="$$(date -u +%Y-%m-%d)" ;\
+        echo "$${pref}ver  $(PACKAGE_VERSION)"  ;\
+        echo "$${pref}date $${reldate}" ;\
+        list='$(DIST_ARCHIVES)'; for i in $$list; do \
+         case "$$i" in *.tar.bz2) \
+            echo "$${pref}size $$(wc -c <$$i|awk '{print int($$1/1024)}')k" ;\
+           echo "$${pref}sha1 $$(sha1sum <$$i|cut -d' ' -f1)" ;\
+           echo "$${pref}sha2 $$(sha256sum <$$i|cut -d' ' -f1)" ;;\
+         esac;\
+       done ) | tee $(distdir).swdb
+
+
 
 gen_start_date = 2011-12-01T14:00:00
 .PHONY: gen-ChangeLog
diff --git a/NEWS b/NEWS
index 498c9da..9dc73f4 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,4 +1,4 @@
-Noteworthy changes in version 1.7.2 (unreleased)  [C21/A1/R_]
+Noteworthy changes in version 1.7.2 (2016-07-14)  [C21/A1/R2]
 ------------------------------------------------
 
  * Bug fixes:
@@ -9,11 +9,11 @@ Noteworthy changes in version 1.7.2 (unreleased)  [C21/A1/R_]
 
    - Remove debug message about unsupported getrandom syscall.
 
-   - Fix build problems related to AVX use
+   - Fix build problems related to AVX use.
 
    - Fix bus errors on ARM for Poly1305, ChaCha20, AES, and SHA-512.
 
- * Internal chnages:
+ * Internal changes:
 
    - Improved fatal error message for wrong use of gcry_md_read.
 
index 80e64fa..2933292 100644 (file)
@@ -56,7 +56,7 @@ AC_INIT([libgcrypt],[mym4_full_version],[http://bugs.gnupg.org])
 #   (No interfaces changed:                   REVISION++)
 LIBGCRYPT_LT_CURRENT=21
 LIBGCRYPT_LT_AGE=1
-LIBGCRYPT_LT_REVISION=1
+LIBGCRYPT_LT_REVISION=2
 
 
 # If the API is changed in an incompatible way: increment the next counter.