Limit exposing rwlock API on GNU/Linux.