Do not use the obsolete VERSION and PACKAGE
authorWerner Koch <wk@gnupg.org>
Thu, 8 Feb 2007 19:01:44 +0000 (19:01 +0000)
committerWerner Koch <wk@gnupg.org>
Thu, 8 Feb 2007 19:01:44 +0000 (19:01 +0000)
ChangeLog
src/oftpd.c

index 37bc8d6..7caf050 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
 2007-02-08  Werner Koch  <wk@g10code.com>
 
+       * src/oftpd.c (main): s/PACKAGE/PACKAGE_NAME/
+       s/VERSION/PACKAGE_VERSION/.
+
        * configure.in: Renamed to configure.ac and converted to modern
        style.
        * acconfig.h: Removed.
index 07bfbad..8f6c234 100644 (file)
@@ -67,7 +67,7 @@ int main(int argc, char *argv[])
     /* verify we're running as root */
     if (geteuid() != 0) {
         if ( argc > 1 && !strcmp (argv[1], "--version")) {
-                printf ("%s %s\n", PACKAGEVERSION);
+                printf ("%s %s\n", PACKAGE_NAME, PACKAGE_VERSION);
                 exit (0);
         }
         fprintf(stderr, "%s: program needs root permission to run\n", exe_name);
@@ -203,7 +203,7 @@ int main(int argc, char *argv[])
                         break;
                 }
             } else if (strcmp(argv[i], "--version") == 0) {
-                printf ("%s %s\n", PACKAGEVERSION);
+                printf ("%s %s\n", PACKAGE_NAME, PACKAGE_VERSION);
                 exit (0);
             } else {
                 print_usage("unknown option");