* configure.ac, m4/po.m4, src/assuan/Makefile.am: Update for newer
authorNIIBE Yutaka <gniibe@fsij.org>
Thu, 1 May 2014 04:58:11 +0000 (13:58 +0900)
committerNIIBE Yutaka <gniibe@fsij.org>
Thu, 1 May 2014 04:58:11 +0000 (13:58 +0900)
autotools.

configure.ac
m4/po.m4
src/assuan/Makefile.am

index c901520..0fd6acd 100644 (file)
@@ -23,11 +23,12 @@ AC_PREREQ(2.52)
 min_automake_version="1.7.9"
 
 # Version number: Remember to change it immediately *after* a release.
-#                 Add a "-cvs" prefix for non-released code.
-AC_INIT(poldi, 0.4.2-cvs, gnupg-devel@gnupg.org)
-
-PACKAGE=$PACKAGE_NAME
-VERSION=$PACKAGE_VERSION
+#                 Add a "-git" prefix for non-released code.
+AC_INIT([poldi], [0.4.2-git], [gnupg-devel@gnupg.org])
+AC_CONFIG_SRCDIR(src/pam/pam_poldi.c)
+AC_CONFIG_HEADERS(config.h)
+AC_CANONICAL_TARGET
+AM_INIT_AUTOMAKE
 
 NEED_LIBGCRYPT_VERSION=0
 NEED_GPG_ERROR_VERSION=0.7
@@ -35,12 +36,6 @@ NEED_GPG_ERROR_VERSION=0.7
 NEED_KSBA_API=1
 NEED_KSBA_VERSION=1.0.2
 
-       
-AC_CONFIG_SRCDIR(src/pam/pam_poldi.c)
-AM_CONFIG_HEADER(config.h)
-AC_CANONICAL_TARGET
-AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
-
 POLDI_CONF_DIRECTORY="${sysconfdir}/poldi"
 AC_SUBST(POLDI_CONF_DIRECTORY)
 
@@ -63,8 +58,6 @@ POLDI_ENABLE_FEATURE(enable_auth_x509, yes, x509-auth, support for X509 authenti
 POLDI_ENABLE_FEATURE(enable_auth_localdb, yes, localdb-auth, support for local-db authentication)
 AC_SUBST(PACKAGE)
 AC_SUBST(VERSION)
-AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE", [Name of this package])
-AC_DEFINE_UNQUOTED(VERSION, "$VERSION", [Version of this package])
 AC_DEFINE_UNQUOTED(PACKAGE_BUGREPORT, "$PACKAGE_BUGREPORT",
                                         [Bug report address])
 AC_DEFINE_UNQUOTED(NEED_LIBGCRYPT_VERSION, "$NEED_LIBGCRYPT_VERSION",
index 0734762..f7c9c06 100644 (file)
--- a/m4/po.m4
+++ b/m4/po.m4
@@ -24,7 +24,7 @@ AC_DEFUN([AM_PO_SUBDIRS],
 [
   AC_REQUIRE([AC_PROG_MAKE_SET])dnl
   AC_REQUIRE([AC_PROG_INSTALL])dnl
-  AC_REQUIRE([AM_PROG_MKDIR_P])dnl defined by automake
+  AC_REQUIRE([AC_PROG_MKDIR_P])dnl
   AC_REQUIRE([AM_NLS])dnl
 
   dnl Release version of the gettext macros. This is used to ensure that
index 56e2eed..f10f7a0 100644 (file)
@@ -20,7 +20,7 @@
 # Modified for Poldi. Based von libassuans Makefile.am.
 
 EXTRA_DIST = mkerrors
-INCLUDES = -I.. -I$(top_srcdir)/include
+AM_CPPFLAGS = -I.. -I$(top_srcdir)/include
 BUILT_SOURCES = assuan-errors.c
 MOSTLYCLEANFILES = assuan-errors.c